Replays won't show up for long games.

Discussion in 'Support!' started by truthtaco, March 8, 2015.

  1. truthtaco

    truthtaco New Member

    Messages:
    24
    Likes Received:
    3
    The problem I'm having is that replays won't show up in the replay tab if it was a long game. In the past I've had intermittent problems where sometimes a replay wouldn't show up, but it seems to have gotten worse and lately the only replays that show up are around 20 minutes or less. Does anyone know of a fix for this problem? I tried uninstalling and reinstalling but I don't know if I probably removed all the old game files.
  2. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,329
    Likes Received:
    2,126
    Replays are stored on Uber's server, so reinstalling won't do anything for those. Do the missing replays show up eventually, or are they just gone forever? I can imagine it takes a while for the longer ones to appear.
  3. truthtaco

    truthtaco New Member

    Messages:
    24
    Likes Received:
    3
    They aren't showing up at all. I've played several long games in the past few days and some short ones, none of the long ones have shown up since.
  4. mikeyh

    mikeyh Post Master General

    Messages:
    1,869
    Likes Received:
    1,509
    This may explain why I'm also missing replays... been meaning to look closer at why.
  5. Planktum

    Planktum Post Master General

    Messages:
    1,060
    Likes Received:
    510
    I've already brought this to the attention of @forrestthewoods.

    He's got people looking into it and sent me a message yesterday - "I've been out of town. Will see where this is at on Monday."
  6. Planktum

    Planktum Post Master General

    Messages:
    1,060
    Likes Received:
    510
    @truthtaco
    @DeathByDenim
    @mikeyh
    @edwood

    Response recevied from @forrestthewoods . See below.
    "We've found that some games take quite awhile to save and then upload a replay file. There's a separate process that scrapes end game data to store in a database for the replay browser to use. If the replay takes too long to save and upload then that browser process misses the files. So all your replays are safe and sound, the browser just doesn't know how to find them.

    I don't have an ETA on a fix. It requires a chunk of work to rejigger a few different things to make sure that all the operations which need to be done are guaranteed to be completed and in the correct order.

    In the meantime if you save the lobbyid before entering a game you will always be able to access the replay for that game. Not a great solution but it's at least something you can do this instant.

    Thanks for your help in tracking this down."
    EdWood likes this.
  7. EdWood

    EdWood Active Member

    Messages:
    533
    Likes Received:
    147
    Wow!!!

    Thank @Planktum, Thx @forrestthewoods Awesome work you guys! At least you found the bug and we have a workaround!!!

    Of course, thx to everyone else that helped in the process!
  8. truthtaco

    truthtaco New Member

    Messages:
    24
    Likes Received:
    3
    I don't know if my problem is the same... as I can't access my replays even if I know the game id or game name. Yesterday I played a game called "5 player ffa" that was 30 minutes long and it never showed up. I have PA stats installed so I looked up the game id which is 299269, and it attempts to launch the game when I put in the id but fails to load.

    If anyone can tell me what I might be doing wrong please let me know.
  9. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,329
    Likes Received:
    2,126
    That's the PA Stats ID, you need the lobby ID, which for you is 11904028623707522432.

    You can get those from the Launch replay link on pastats.com ( http://pastats.com/chart?gameId=299269 )
  10. truthtaco

    truthtaco New Member

    Messages:
    24
    Likes Received:
    3
    That worked! Thanks for the help.

Share This Page