Rendering issues on linux with PA 89755

Discussion in 'Mac and Linux' started by dalmaat, October 31, 2015.

  1. dalmaat

    dalmaat New Member

    Messages:
    2
    Likes Received:
    0
    Hello,

    I use PA 89755 from steam and experience some display problems when starting a game.
    As you can see from the screenshot, some (random) parts of the screen are not properly displayed.

    Fortunately the display is back to normal after a few minutes when I can select some units/buildings that force rendering those parts.

    I checked the known issues on linux, but did not find any reference to this problem.
    Does anybody has a clue on the issue and how to workaround it ?

    My setup:
    debian jessie amd64
    opensource radeon driver (Gallium 0.4 on AMD RV730 - Mesa)
    PA 89755 (steam)

    Attached Files:

    • PA.png
      PA.png
      File size:
      806.5 KB
      Views:
      11
  2. n00n

    n00n Active Member

    Messages:
    346
    Likes Received:
    205
    I've not had said issue myself. Are you running with the --software-ui option? Does pressing F5 help? If not toggling fullscreen should force a redraw (press alt+enter twice).
  3. dalmaat

    dalmaat New Member

    Messages:
    2
    Likes Received:
    0
    F5 and fullscreen toggles indeed refresh the screen. However while some parts are rendered properly, some others are not. Basically I need to do it some times to get a better display :)
    Fortunately the --software-ui option works pretty well and delivers a nice display.
    Thanks for the tips

Share This Page