[REL] ProfilePic+ [72996]

Discussion in 'Released Mods' started by LavaSnake, November 5, 2013.

  1. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
    Recent Changes:
    • v1.1 - Awesomeness. I won't say anything more. Just update and play a few games...
    • v1.2 - Support for PAMM 3.x and a new, easier setup.
    • v1.3 - Prevents possible mod conflicts.
    • v1.4 - Now automatically finds your profile pic on the Uber forums if you don't have one set.
    • v1.5 - Support for displaying the player's PA Stats Ladder info and a bug fix.
    • v1.6 to v1.67 - Bug fixes.
    • v2.0 - Gamma support and a complete redesign with loads of great new features!
    • v2.1 - Added settings option auto-configure the image to display your PA Stats Ladder pic.
    • v2.2 - Update for the find PA Stats Ladder pic option to use the new PA Stats server.
    • v2.3 - Update for compatibility with build 72996.

    ProfilePic+ is a powerful mod that lets you set a profile picture, a tracking/sig picture, and custom HTML snippets for PA's main menu. It's easily configurable from PA's UI settings tab and will even get your Uber Forums profile pic automatically. Here's a screenshot of what the mod does:
    ProfilePicPlus Mod.PNG

    This mod uses PAMM so make sure you have that set up first and then follow these steps:
    1. Download and select this mod in the mod manager.
    2. Fire up PA and log in.
    3. It will automatically find your Uber Forums profile pic and add it to the main menu.
    4. You can head over to the UI tab of the settings menu to setup the other options or change the pic.
    5. Enjoy!
    Please note that this mod requires an internet connection to show your profile pic.
    Last edited: October 8, 2014
  2. Raevn

    Raevn Moderator Alumni

    Messages:
    4,226
    Likes Received:
    4,323
  3. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
  4. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
    UPDATE! (I guess this is the best way to tell people to update the mod. :D)
  5. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
  6. stuart98

    stuart98 Post Master General

    Messages:
    6,008
    Likes Received:
    3,888
    Broken in the new build.
  7. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
    Thanks for telling me. I'm on vacation right now but will fix it as soon as I get back. I should have an update out by Sunday.
  8. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
    Seems to actually work fine. Could you run the debugger (\Planetary Annihilation\PA\Coherent\Debugger\) and post a screenshot of any errors?
  9. cptconundrum

    cptconundrum Post Master General

    Messages:
    4,186
    Likes Received:
    4,900
    I haven't tried it, but the no blackscreen fix mod can cause peoblems with loading pictures if you use relative urls.
  10. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
    This mod doesn't use relative urls and it seems to work fine in my testing with or without that mod.
    cptconundrum likes this.
  11. stuart98

    stuart98 Post Master General

    Messages:
    6,008
    Likes Received:
    3,888
    It isn't showing up at all. Profile pic is still default delta one, and the random unclickable button isn't showing up.
  12. cptconundrum

    cptconundrum Post Master General

    Messages:
    4,186
    Likes Received:
    4,900
    Are you getting debugger errors? Did the mod somehow get disabled?
  13. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
    There is no button. You should be able to click the spot where the delta commander would be to bring up the settings dialog. If you haven't set a pic it will default to blank.
  14. stuart98

    stuart98 Post Master General

    Messages:
    6,008
    Likes Received:
    3,888
    I'm referring to the random splash button.

    The mod is clearly broken for me, as none of its features are working. I don't know why it's working for you. Did you reinstall the mod?
  15. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
    Nope. The random splash button should never do anything. It's just a fun little message that pops up from time to time.
  16. stuart98

    stuart98 Post Master General

    Messages:
    6,008
    Likes Received:
    3,888
    The random splash isn't showing up though at all, which is exactly what I have said since I started posting in this thread.
  17. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
    Sorry, I misunderstood you. It's only supposed to show up every once in awhile and I just tested it and it works fine.
  18. mishtakashi

    mishtakashi Active Member

    Messages:
    369
    Likes Received:
    217
    I havn't had any trouble with this mod in the last patch
  19. LavaSnake

    LavaSnake Post Master General

    Messages:
    1,620
    Likes Received:
    691
    Glad to hear it! Any suggestions for improving this mod? I'm honestly not sure how many people use it and what they think of it.
  20. cptconundrum

    cptconundrum Post Master General

    Messages:
    4,186
    Likes Received:
    4,900
    Could it look for your forum picture? Not that it would help me at all...

Share This Page