[REL] Auto Factory

Discussion in 'Released Mods' started by trialq, January 25, 2014.

  1. trialq

    trialq Post Master General

    Messages:
    1,295
    Likes Received:
    917
    You're right, there is a problem with this mod in galactic war. I couldn't reproduce your issue, but auto factory failed to do anything. It was there in the UI and settings, just no building from factories when it's meant to. Works fine in multiplayer.

    What a pain :confused:
  2. wondible

    wondible Post Master General

    Messages:
    3,279
    Likes Received:
    2,084
    I thought I hadn't seen it, but I don't often empty my selection. (And if I remember to do that, I could remember to go queue stuff up ;^) )
  3. Quitch

    Quitch Post Master General

    Messages:
    5,265
    Likes Received:
    5,987
    Auto Factory settings have been missing from the UI since launch.
  4. trialq

    trialq Post Master General

    Messages:
    1,295
    Likes Received:
    917
    Damnit, I'll try and fix it this week. I did check the mod but only noticed the different-sized icon in the bottom bar.
    Quitch likes this.
  5. trialq

    trialq Post Master General

    Messages:
    1,295
    Likes Received:
    917
    Updated to v1.8.2:
    • Fixed settings menu, settings are now visible again (and by chance are ordered nicely at 1080P). Thank you @wondible, instant sandbox has a nice example of what was needed for the fix
    • Fix toggle in options bar to be in line with others
    • Default unit from T1 bot factory changed from grenadier to dox, to reflect balance changes

    af_settings_v1.8.2.png

    @startege1
    zaphodx and Quitch like this.
  6. Quitch

    Quitch Post Master General

    Messages:
    5,265
    Likes Received:
    5,987
    The UI is showing my T1 bot choice as Dox, but it still builds Grenadiers.
  7. trialq

    trialq Post Master General

    Messages:
    1,295
    Likes Received:
    917
    Maybe a bug due to me changing the default from grenadier to dox. Try picking the fabber then saving and exiting settings, then go back in settings and change it to what you want.
    Quitch likes this.
  8. trialq

    trialq Post Master General

    Messages:
    1,295
    Likes Received:
    917
    Another issue that may or may not have been the cause for what you saw: If you change a setting whilst playing a live game, you currently have to press F5 for the setting to take effect in that game. It used to be that navigating away from the settings menu caused a live_game refresh, which refreshed the loading of the settings for you. Some time ago they changed it so that this doesn't happen (making navigation to/from settings more responsive). It's not a massive issue as you'd rarely want to change a setting from in-game.
    Quitch likes this.
  9. Swatti

    Swatti Member

    Messages:
    31
    Likes Received:
    7
    Is there a reason this wont work in galactic war? Or did i mess something up?

    Got the AF button and the options but stuf wont build...
  10. Swatti

    Swatti Member

    Messages:
    31
    Likes Received:
    7
    I take it this mod is not being developed anymore?
  11. Quitch

    Quitch Post Master General

    Messages:
    5,265
    Likes Received:
    5,987
    Yeah, that seems like a totally sound assumption what with the last update being a whopping TEN DAYS AGO.

    :rolleyes:
  12. trialq

    trialq Post Master General

    Messages:
    1,295
    Likes Received:
    917
    @Swatti
    I saw your post but forgot to reply. I checked it out, fixed it, and the fix is now on PAMM. Thank you for letting me know. The problem was that in applying the galactic war buffs, the spec ids change from "whatever/the/path/is.json" to "whatever/the/path/is.json.player".

    v1.8.4:
    • Fix to work with galactic war
    Quitch likes this.
  13. Swatti

    Swatti Member

    Messages:
    31
    Likes Received:
    7
    Whoops, didnt look at the date, was on my phone... HUGE thx for the update

    EDIT: is there a reason this only seems to work on planets i "look at" ?
    Last edited: September 24, 2014
  14. trialq

    trialq Post Master General

    Messages:
    1,295
    Likes Received:
    917
    If this is the case, I think it's a limitation of the 'select all idle factories' function used. Fixing it if that is the case is not so simple, but doable.

    edit: Maybe.
  15. Swatti

    Swatti Member

    Messages:
    31
    Likes Received:
    7
    Small workaround, pip screen the planet, win!
  16. Fr33Lancer

    Fr33Lancer Well-Known Member

    Messages:
    595
    Likes Received:
    288
    Re-enabled the mod recently, and I'm getting some crash at end game / screen.
    I remember I posted something similar here, but for some reason, it seems I didn't here.
    Didn't had the debugger open now, but PA log says :
    Does it remind you something / Is it possible to fix ?

    EDIT : Nevermind, seems to be another mod since disabling it doesn't solve it
    Last edited: October 1, 2014
  17. trialq

    trialq Post Master General

    Messages:
    1,295
    Likes Received:
    917
    Has anyone noticed any glitchy UI involving selection with this mod recently? It used to be a minor issue, because the way the mod and user select things is the same, and I can't control when the user selects things. Optimisations over the past months may have sped up selection, which may have made the glitch much less apparent. In particular, any high APM users of this mod notice any issues?
  18. Quitch

    Quitch Post Master General

    Messages:
    5,265
    Likes Received:
    5,987
    The mod is queuing T1 units from T2 factories.

    I haven't noticed any UI issues.
  19. trialq

    trialq Post Master General

    Messages:
    1,295
    Likes Received:
    917
    That's an unintended feature ever since T2 factories could produce T1 units. That's why the T2 factory options have dropdowns that say "same as T1" instead of "none". At worst, given default threshold settings, the factory will produce a T2 unit followed by a T1 unit. I've done it this way to minimise usage of the selection system, instead of sub-selecting factory types. The mod selects all idle factories at once; then sending a "build ant" command causes all selected factories that can build ants to add them to their queue.

    Good to hear you haven't had any UI issues. Maybe I'm working around something that's not really a problem anymore. In the long distant future I may try sub-selecting factories, to cleanly separate T1 and T2 again.
  20. fragal0t

    fragal0t New Member

    Messages:
    15
    Likes Received:
    3
    I liked this mod but the issue i had is the moment a factory is started to be built it already will que up units I don't want, even before it's done being built.

Share This Page