Random crashes in archlinux with Intel HD 4000

Discussion in 'Mac and Linux' started by ouroboros88, March 9, 2015.

  1. ouroboros88

    ouroboros88 New Member

    Messages:
    7
    Likes Received:
    2
    I recently managed to get past some issues with fullscreen PA, but I'm now having more serious problems: I get random crashes once the game is loaded up. So far, they seem to mostly be once I get into the "select starting area" screen.

    I've had to paste in link text to some pastebins and to the uber crash report generated, because apparently neither crashes.uberent.com nor the sprunge pastebin are whitelisted, and I can't just put the logs in code blocks because it exceeds the 1000 char limit. Sorry for the inconvenience.

    Anyway, here's a recent crash report: crashes.uberent.com/report/index/f41b8431-6c8e-4770-93de-917782150308. The logs are as follows:
    • PA log: sprunge.us/XNVM
    • Server log: sprunge.us/aAAh
  2. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,328
    Likes Received:
    2,124
    Do any of the graphics settings have any effect on this? I mean, when you set everything to the lowest possible setting, do the crashes still occur? I'm just wondering if it's a specific algorithm that's crashing it, since my Intel HD 4000 has no trouble. Though I think I am still at Mesa 10.1.3 instead of 10.4.5 as you are.

    Also, you say the crashes are mostly in the select starting area screen, i.e. when the 3D engine has just been started. But where do the other crashes occur? After that or even before starting the 3D engine?

    On a completely unrelated, users with less than five messages are not allowed to post URLs, so you should be able now, since this was your 5th post. And if you use the "Upload a File" button on this forum, you don't need sprung.us or pastebin.com anyway.
  3. ouroboros88

    ouroboros88 New Member

    Messages:
    7
    Likes Received:
    2
    I've done a bit more testing, and the crash is a lot more replicable than I initially thought. The crash happens consistently when I try to enter a specific zoom level above a planet; specifically, if I click on the planet view and zoom in 5 times, the game freezes, then crashes. I don't know if anything important happens at that zoom level? Maybe it starts to render units and terrain features in more detail?

    This seems like it may just be a bug. Perhaps I should report it to the developers.
  4. ouroboros88

    ouroboros88 New Member

    Messages:
    7
    Likes Received:
    2
    Oh, and I tried lowering graphics settings, but no change.
  5. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,328
    Likes Received:
    2,124

Share This Page