Narwhal still got wrong mounted gun...

Discussion in 'Planetary Annihilation General Discussion' started by radongog, August 10, 2014.

  1. squishypon3

    squishypon3 Post Master General

    Messages:
    7,971
    Likes Received:
    4,356
    Yes but these weapons aim downward as they have an aim bone and can move said bone to point at a target. Or that's how most units work, other than like fighters and stuff, which actually use their base_armature as an aim bone! =o
  2. Zainny

    Zainny Active Member

    Messages:
    123
    Likes Received:
    146
    In the video I watched where @ZaphodX zoomed right in (maybe he can link to it...I don't remember which one it was) you can see the anchors firing at ground units while still having the guns facing (and animating) as if firing at something on a horizontal plane. It's definitely a bug.
    stuart98 and squishypon3 like this.
  3. squishypon3

    squishypon3 Post Master General

    Messages:
    7,971
    Likes Received:
    4,356
    Really? That is weird then, maybe their anti-ground weapon's aim bone is the base_armature and the anti-orbital one's is the actual weapons. Someone should see what happens when both are attacking or something. We're the shots coming out of no-where, or were they coming from the weapons?
  4. temeter

    temeter Well-Known Member

    Messages:
    501
    Likes Received:
    305
    Afair the shots come from the correct spot, the guns just don't point downwards. I started during gamma and can't even remember a time when they worked correctly.
    squishypon3 likes this.
  5. Quitch

    Quitch Post Master General

    Messages:
    5,764
    Likes Received:
    6,035
    Originally they didn't fire at the ground. I suspect they were never updated to account for the change.
    squishypon3 likes this.
  6. radongog

    radongog Well-Known Member

    Messages:
    638
    Likes Received:
    295
    Well, it has been fixed!
    I don´t know when it happened, but it´s fixed! ;)

    Saidly, it doesn´t look like the wrong-headed AntiAir has been fixed... :eek:

    Attached Files:

  7. thetrophysystem

    thetrophysystem Post Master General

    Messages:
    7,050
    Likes Received:
    2,874
    Thats... not so much a bug, as it is the game has limitations on where the turret can rotate, and the actual bullet can come out at an angle farther than the turrets can fire.

    The gil-e anti-missiles without ever turning either, not a bug just a matter of turnVS reactiontime.
  8. davostheblack

    davostheblack Well-Known Member

    Messages:
    364
    Likes Received:
    313
    I'm missing something; what's wrong with the Narwhal exactly? it has AA and a front mounted cannon, it appears to function as so from a distance, what's not working correctly?
  9. squishypon3

    squishypon3 Post Master General

    Messages:
    7,971
    Likes Received:
    4,356
    The main cannon used to be facing the wrong way for no reason. :p
  10. Zainny

    Zainny Active Member

    Messages:
    123
    Likes Received:
    146
    No, it's very clearly a bug. It's not something that's up for discussion either - anybody normal reasonable person (including the folks at Uber) who looked at the behaviour would come to the same conclusion.
  11. burntcustard

    burntcustard Post Master General

    Messages:
    699
    Likes Received:
    1,312
    They all have broken animations.

    Even the sunfish (the "gunboat"?) has it's projectiles appear from nowhere.
    igncom1 likes this.
  12. thetrophysystem

    thetrophysystem Post Master General

    Messages:
    7,050
    Likes Received:
    2,874
    Most of these can be fixed. The narwhal and even maybe anchor for instance can have the model fakely twisted to track with the way it looks facing the correct looking way. For gil-e, there is no fix besides making it not work as intended anyway.
  13. Fr33Lancer

    Fr33Lancer Well-Known Member

    Messages:
    595
    Likes Received:
    288
    It's not because it's mounted right straight out of factory that it is fixed :rolleyes:
    I just tried (75817) and no, it is still buggy :
    upload_2014-12-7_13-24-21.png
    radongog, stuart98 and kayonsmit101 like this.
  14. radongog

    radongog Well-Known Member

    Messages:
    638
    Likes Received:
    295
    I haven´t used it yet. But hey, one half of the problem is fixed. Previously it was wrong-headed AND angles were applied the wrong way---the first one is gone now! :D And this was clearly the main problem I was adressing in this thread! :p
    Anyways, you´re mentioning a serious problem!
    How about doing a seperate, new thread on that issue: I´m not good at doing those nice shots you can do...
    ...and the heading isn´t suitable anymore!

Share This Page