Mac and Linux: Getting Started

Discussion in 'Mac and Linux' started by garat, June 14, 2013.

  1. geopirate

    geopirate New Member

    Messages:
    10
    Likes Received:
    2
    Well I'm on 313 and also not experiencing the cursor problem...

    EDIT: Correction I was not experiencing this on prior builds but I just downloaded 49900 and the bug is now present for me.
    Last edited: June 22, 2013
  2. eeyrjmr

    eeyrjmr Member

    Messages:
    137
    Likes Received:
    13
    right so there maybe something in the drv versiobn then

    ill downgrade in a bit
  3. gillza

    gillza Member

    Messages:
    42
    Likes Received:
    18
    Im on mint14 (ubuntu 12.10) with cinnamon. I have tried both nvidia-319 and downgraded to 313. Experience the flickering and disappearing cursor (and an area around cursor) on BOTH drivers.
  4. eeyrjmr

    eeyrjmr Member

    Messages:
    137
    Likes Received:
    13
    ok I can confirm it isn't todo with driver version:
    313.30 & 319.23 both exhibit the same behaviour with respect to loss of cursor, blinking cursor with this present build.

    The fact some people say it doesn't affect them (and the fact from what I have seen it does appear to X11, just not on the top layer) would possibly indicate its an Xorg thing and the recent build of CoherentUI might not fully play with it.

    I am running:
    xorg-drivers-1.14
    xorg-x11-7.4-r2
    xorg-server-1.14.1.901
  5. rkfg

    rkfg Member

    Messages:
    35
    Likes Received:
    2
    My xserver-xorg-core version is 1.12.4-6, xserver-xorg is 7.7+3.
  6. laseek

    laseek New Member

    Messages:
    88
    Likes Received:
    0
    It can be due to a bunch of reasons - GPU config settings, xorg conf settings & modules, if composite or direct rendering is being used or not.

    Most of us have been attaching what info we think relevant but we don't really have a definitive set of settings/config that can help narrow down the problem.
    I was kinda hoping Uber would hop in and ask/give some info we can use to help narrow it down - or at least what info they need to help identify it.

    The issue started appearing when changes to PA around sync & the cursor were implemented recently (about 2 builds ago). The problems being reported all relate to flicking or the cursor - where cursor issues are bleeding through underlying windows and/or the cursor being an enlarged square.
    The enlarged square type issues might be related to how the texture is applied to the cursor.

    Screen update issues look also to be related to the sync config.

    The most reliable config I have at the moment, that pretty much eliminates tearing & display corruption at the expense of mouse issues (game is fairly playable but painful), with AMD & the latest proprietary stable drivers is:
    Disable Tear Free
    AA Use Application settings with the standard filter
    AA Mode performance
    Anisotropic Filtering disabled
    Wait for Vert refresh Off unless App specifies & Catalyst AI Disabled.

    I've been testing various options for tweaking the xorg.conf file & exploring some env vars that might help (from http://www.mesa3d.org/envvars.html) - but nothing definitive at the mo.

    Anybody tries the beta AMD drivers?
    It was causing segfaults on earlier builds but that might have been fixed in recent builds of PA.

    xorg - 1.13.3
    Kernel - Linux 3.9.7-030907-generic
    OpenGL - 4.2.12217 Compatibility Profile Context 9.012
    Dual Screens running off one GPU as Multi-Display desktop

    Attached an xtrace output which might help if somebody knows how to read 'em.
    Need to dig around for the proto files to help decode it a little btter.

    Attached Files:

  7. liamdawe

    liamdawe Active Member

    Messages:
    345
    Likes Received:
    61
    Just updated and still for me I am seeing no issue, works as expected :)
  8. laseek

    laseek New Member

    Messages:
    88
    Likes Received:
    0
    Attached an external recording of the issue.

    0:17 shows the problem
    0:23 the mouse leaves the PA game window - and you see the display update.
    At 0:40 & right at the end you see another example.

    Compressed due to the file extension not being allowed

    Attached Files:

  9. pyosanoos

    pyosanoos New Member

    Messages:
    2
    Likes Received:
    0
    Flickering here too.

    Gentoo, amd64.
    nvidia-drivers 319.23
    xorg-server 1.13.4
    PA 50000
  10. aeonsim

    aeonsim Active Member

    Messages:
    195
    Likes Received:
    42
    Awesome 50083, is the first stable OSX (10.8.4) build as far as I can tell able to completely explore the map and wipe out the AI's with a decent army for 30+mins with out any Hangs. Performance is a bit iffy especially when zoomed out but otherwise awesome!
  11. pedersen

    pedersen New Member

    Messages:
    13
    Likes Received:
    1
    Ubuntu 12.04, v.50083 here, and I'm very happy with this build. For the first time, I was able to get in, and play the game from start to finish. Prior builds had some extreme display corruptions going on (too weird to even describe, stuff like inability to see units except when zoomed way out, buildings that when placed had parts across the planet, etc).

    Those issues did not happen at all for me last night. I was able to explore the planet, find the AIs, and take them out. The display was clean almost all the time. The only exception was the mouse cursor itself: When visible, it had a black square surrounding it that seemed to show random parts of other windows.

    Nice job! From what I'm seeing here, a few more minor issues, and then it's just going to be time to focus on the game balance, the AI, etc.

    I do have one question: How are people able to determine the framerates they're getting? I'd like to check and see what mine are, but I just don't know how.
  12. SXX

    SXX Post Master General

    Messages:
    6,902
    Likes Received:
    1,833
    Press "P" in game.
  13. leesam

    leesam New Member

    Messages:
    12
    Likes Received:
    0
    I downgraded my AMD drivers to 13.4-4. I can launch PA now but i'm seeing this same flicker tear issue. I'm running 50083.
  14. truett

    truett New Member

    Messages:
    1
    Likes Received:
    0
    This may be somewhere else but I am having issues. I read about how the Mac build was stable. I have previously activated my key, converted it to Steam and logged on briefly. Now, when I try it, it says my key is not active but to go to the store and activate them (which is shows is active). When I try to play through Steam it tells me the same thing. Any help would be appreciated! Thanks!
  15. aeonsim

    aeonsim Active Member

    Messages:
    195
    Likes Received:
    42
    Try relinking your Uber and Steam accounts using this link:

    https://uberent.com/user/LinkSteam
  16. freedonnadd71

    freedonnadd71 New Member

    Messages:
    1
    Likes Received:
    0
    @truett & @aeonsim -

    I am having the same issue. I had used the windows version when it first came out, then I tried to convert over to Mac today. I was able to convert my key, link my steam account to my ubernet account(https://uberent.com/user/LinkSteam), and successfully download and install within Steam. However, when i try to login through the game interface, it is saying my account it not activated. Is there another step I am missing???


    EDIT - I waited about 30 minutes and tried to login again, and this time it worked. Maybe there is a slight timing issue with connecting the accounts. In any case, I can play now :)
  17. liamdawe

    liamdawe Active Member

    Messages:
    345
    Likes Received:
    61
    Does Linux have a 32bit version yet? Can't check as I'm on 64bit, waiting for a friend to be able to get in on the Alpha.
  18. eeyrjmr

    eeyrjmr Member

    Messages:
    137
    Likes Received:
    13
  19. MCXplode

    MCXplode Active Member

    Messages:
    196
    Likes Received:
    28
    32 bit a waste of time, by the time the Galatic war comes out with entire solar systems 32 bit addressing and number crunching will not cut it. plus twice as many registers used on the cpu in 64bit long mode 16 integer and 16 sse floating point used on 64bit cpu, only half the registers used on the cpu in 32bit mode. The advantage of using 64bit integers instead of floating point many other coding efficiency advantages. game already uses 2GB ram just for 1 planet I imagine will use 4GB for entire solar system battles. maximum RAM availabe to 32bit apps is 3GB with PAE compiled in the 32bit app otherwise normal 32bit app onlyaddresses 1.5GB ram, the rest just spills into virtual memory :ugeek:
  20. garat

    garat Cat Herder Uber Alumni

    Messages:
    3,350
    Likes Received:
    5,382
    Linux and Mac will not be getting 32-bit versions, at least not any time soon. Mac support for 10.6 would be needed for 32-bit, and we've already established that for the tiny number of people that are still on 10.6 and 32-bit, it's just hard to justify spending weeks of time on it when we have so many things to be working on it. As for Linux, it's basically the same. It may not be weeks to make 32-bit work on Linux, but how many 32-bit Linux users are out there? Even if it only takes a week to get 32-bit working on Linux, that's time not being spent on features and making sure the existing platforms continue to improve.

    If there ends up being a huge demand, we can of course revisit this, but.. if you're running a 64-bit CPU, consider upgrading your kernel. It's been 5 years since 64-bit started to become the default shipping CPU type on almost every machine out there.

Share This Page