Linux: Working Distributions

Discussion in 'Mac and Linux' started by garat, June 25, 2013.

  1. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    You try to remove config directory:
    /home/me/.local/UberEntertainment/
    Then GPU cache and all settings will be cleaned and game probably will start work again.
  2. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    That was your suggestion back on October 10th; didn't work then and still doesn't. I appreciate the attempt though. If you have any other ideas in mind I'm all ears!
  3. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    Still no dice on latest build. shrug
  4. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    OMG I CANNOT BELIEVE IT.

    I found out (by chance) what the problem was. About a month ago I used gtk-chtheme and set the theme to oxygen. Chrome started having a huge problem with it, so I just set it back to ClearLooks and noticed that things with Chrome were back up to snuff. Gave PA a shot just out of the blue and it freaking works.

    How stupid. Sometimes Linux really *@&ses me off.

    SXX, thank you again for trying to help.
    shootall likes this.
  5. georgejhuff

    georgejhuff New Member

    Messages:
    3
    Likes Received:
    1
    Hello Thread,

    I'm pleased to report that PA is working flawlessly on Fedora 19 (64bit). I've started several games with zero problem and very decent performance. There have been no crashes, no core dumps, no distorted sound or video, or other problems. The game just works and works well.

    Details follow:

    OS: Fedora release 19 (Schrödinger’s Cat)
    CPU: Intel(R) Core(TM)2 Extreme CPU Q9300 @ 2.53GHz
    Video: 01:00.0 VGA compatible controller: NVIDIA Corporation G92GLM [Quadro FX 3700M] (rev a2)

    Nvidia modules:
    kmod-nvidia-3.11.10-200.fc19.x86_64-331.20-3.fc19.1.x86_64
    akmod-nvidia-331.20-3.fc19.x86_64
    xorg-x11-drv-nvidia-libs-331.20-4.fc19.x86_64
    kmod-nvidia-3.11.8-200.fc19.x86_64-331.20-2.fc19.1.x86_64
    xorg-x11-drv-nvidia-libs-331.20-4.fc19.i686
    kmod-nvidia-331.20-3.fc19.1.x86_64
    xorg-x11-drv-nvidia-331.20-4.fc19.x86_64

    The one catch was the need to install 32bit drivers to address a Steam issue.
    shootall likes this.
  6. yrrep

    yrrep Member

    Messages:
    67
    Likes Received:
    79
    Just a heads up, rtmpdump on Arch Linux received an update recently that breaks PA. It now includes librtmp.so.1 instead of librtmp.so.0. Creating a symlink to the new version seems to be working so far for me.
  7. royper

    royper New Member

    Messages:
    4
    Likes Received:
    0
    Unfortunately, this is not true for me. I have a lot of graphic issues and am still pinpointing down, what causes them.
  8. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,326
    Likes Received:
    2,118
    Do you also use NVidia like georgejhuff or something else? And open source drivers or proprietary?
  9. MCXplode

    MCXplode Active Member

    Messages:
    196
    Likes Received:
    28
    stopped updating ArchLinux a little over a year ago PA seems to work better on libs that are not to new and cutting edge. Still able to update AMD Catalyst through AUR(had to edit out "static libs and libtools" from package install file to compile, can't update much of anything else but a few packages. have to run --software-ui but performance is still good, main issue with CoherentUI's version of Chromium 28 thats the main thing that needs to be fixed. Running custom kernel compile 3.6.7-amd64 and Xorg 1.12 newer catalyst drivers work better on older kernels and xorg. Have LXDE and openbox window manager which supports fullscreen.
  10. royper

    royper New Member

    Messages:
    4
    Likes Received:
    0
    I'm using the gpu of my i7-3520M which is the HD4000 with foss drivers.
    At the moment I have problems with the shaders etc. so that almost no texture etc. is displayed.
  11. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    Please check this link:
    http://steamcommunity.com/app/233250/discussions/2/810938082193900075/
    If you have no textures it's most likely mean you just don't have S3TC installed.

    To play on open source drivers you basically need two workarounds: for broken cursor and for crash on startup. After these applied you should get fairly well gameplay on HD4000 because I'm tested PA on HD2500 and it's works awesome.

    Only thing shaders break it's FXAA and it's clearly not "must have" feature for your integrated GPU.
  12. derwookie

    derwookie New Member

    Messages:
    1
    Likes Received:
    0
    I have only a Black Screen when i run PA (Steam)
    i can't find the Problem.

    SYSTEM:
    AMD Phenom II X4 BlackEdition (3.1 Ghz)
    16 GB RAM
    Ubuntu Studio 13.10 64 bit (base on Ubuntu 13.10 "Realtime Kernel")
    Grafik:
    ATI HD 7850 2 GB (Lastet driver)


  13. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
  14. liamdawe

    liamdawe Active Member

    Messages:
    349
    Likes Received:
    61
    You can add Manjaro to the list of working distro's, no extras required.
  15. davew69

    davew69 New Member

    Messages:
    5
    Likes Received:
    0
    Hello

    Havn't played this genre of game since C&C Red Alert. This really looked awesome so thought I'd give it a go.

    I (finally) got version 59607 running on Ubuntu 13.10 64bit on a Dell XPS 15 Intel SandyBridge I5; 6GB RAM; Nvidia 2GB 540M

    I have the game running using Primus and proprietry Nvidia drivers as I do with Steam and other games.

    I had to use the --software-ui flag to run though. Then ctrl-p to show info in order for UI to show. Once in game I can turn of the info. It isn't flawless though. I get black blocks appearing and the menu is black. Icons to the right.

    Performance is great though and really fun to play. Shame there's no save

    Getting information on how to run was really difficult though. There's a lots of mixed info. Different PA versions, distros 32bit or 64bit, drivers, GPUs, etc
  16. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    As long as I know you just need to make Coherent work on Nvidia as well then it's should work fine.

    I'm actually have topic with all known issues here:
    http://steamcommunity.com/app/233250/discussions/2/810938082193900075/
    But I'm lucky person who successfully avoid Nvidia graphics on laptops, so I have no proper data on issues with Optimus. If somebody help me here then I'll add it to topic.
  17. davew69

    davew69 New Member

    Messages:
    5
    Likes Received:
    0
    Thanks SXX,

    I have read loads of your posts. Some are old, some newer and they have been invaluable.

    The game does works great, just this issue with ctrl-p. Is this optimus doing this? I don't want to try the nvidia-prime drivers until they are confirmed as stable.

    Unfortunately I never knew about optimus before I purchased my Dell laptop. Dell are the only company I know of that offered a buy now pay later scheme.

    I'm happy to test out any issues and report back on optimus/nvidia specific problems.
  18. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    Not actually. Software UI mode is broken on all platforms at moment and it's a game bug, but developers never said they ever want to support this option and it's obviously not priority for them.

    Still original problem with game is obviously caused by lack of proper Optimus support on Linux.

    You don't actually need prime drivers. Main problem with primusrun/optirun run PA on discrete graphics, but Coherent still running on integrated one.

    So as idea you just need to edit host/CoherentUI_Host script and add force Coherent to run on Nvidia. Still I remember there was problems related to that, but I'm have no idea about current status.

    If you'll able to fix your problems let me know and then we can built proper how-to for other players with same problem.
  19. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,326
    Likes Received:
    2,118
    The current status is still problematic. With build 59607 it still doesn't work properly though it at least doesn't crash or give a black screen. This is what I get:
    optirun.jpg
    So, metal spots (decals) are not always visible but may reappear depending on zoom level. The metal spot icons (green dots), selection boxes and unit icons are invisible. The UI doesn't react to resize events. No shader compile errors though. But yeah, not working very well.
    (That's with optirun/bumblebee version 3.2.1 and NVidia 331 drivers and virtualgl 2.3.3)
  20. jorgenpt

    jorgenpt Uber Programmer Uber Alumni

    Messages:
    164
    Likes Received:
    390
    If anyone has had issues that were *not* the libc issue, I'd love for you to retry with today's update and give me feedback here. :)
    We've switched to using an isolated runtime, in the same way that Steam games do, and hopefully that should smooth out distribution (and package version) differences..
    mkrater likes this.

Share This Page