Linux: Working Distributions

Discussion in 'Mac and Linux' started by garat, June 25, 2013.

  1. milanfin

    milanfin New Member

    Messages:
    7
    Likes Received:
    0
    I have the exact same issue, beta 13.10 drivers with radeon hd 6850 adn Linux mint 15.
  2. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    Currently there is no fix for that for AMD drivers, but you can play with open source drivers before this one is fixed.
  3. nihilusiua

    nihilusiua New Member

    Messages:
    5
    Likes Received:
    0
    @SXX
    Maybe you have an awesome tutorial for nouveau driver as you do with the radeon driver? Would be glad to test it on other machine.
    Thanks in advance.
  4. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    You know that nouveau is really cripped driver, there is no reclocking support for most of recent cards and I really doubt how feature complete it is. I don't see any reason why anybody might want to use open source driver with Nvidia GPU.

    Any thought?
  5. milanfin

    milanfin New Member

    Messages:
    7
    Likes Received:
    0
    Does anyone know any estimation on the support for proprietary GPU drivers?
  6. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    shootall likes this.
  7. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    Not sure why I can no longer run PA in Debian. It used to work a few versions ago. With v55089, I get the initial screen with the option to Accept or Decline. When I click Accept, it just locks up. Background sound still going. This is the last message I get when clicking the Accept button:

    Code:
    6929 18:39:35.494900 W | PID: 6931 | 6931 18:39:35.494841 Requesting resource read for coui://ui/alpha/shared/css/images/ui-bg_flat_65_000000_40x100.png with internal id 145 reported FAIL
    
    Did see some other errors earlier on...

    Code:
    6929 18:39:33.129891 W | PID: 6931 | 6931 18:39:33.127331 [6931:6931:ERROR:(0)] Failed to load /home/(myusername)/src/PA/PA/host/ui_resources_100_percent.pak
    Some features may not be available.
    6929 18:39:33.493208 W | PID: 6931 | 6931 18:39:33.485034 Requesting resource read for coui://ui/mods/ui_mod_list.js with internal id 37 reported FAIL
    6929 18:39:33.518211 W | PID: 6931 | 6931 18:39:33.509973 Requesting resource read for coui://ui/mods/ui_mod_list.js with internal id 41 reported FAIL
    6929 18:39:33.577646 W | PID: 6931 | 6931 18:39:33.571048 Requesting resource read for coui://ui/mods/ui_mod_list.js with internal id 98 reported FAIL
    
    Any ideas? Are there some default settings I need to try to clear out somewhere? This run was after blowing away everything in the PA dir, then re-extracting and running.
  8. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    I can only say that those messages from log are not related to your problem. :)

    PS: Also Coherent store it's data in ~/.local/Uber Entertainment/Planetary Annihilation/localstore
    And all game settings (include hotkeys, saved solar systems and planets) stored here as well.
  9. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,329
    Likes Received:
    2,126
    That actually doesn't seem to be true anymore. Settings are saved in the installation directory in media/user nowadays it seems? I had erased my ~/.local/Uber Entertainment for testing purposes and it never came back, though settings are still saved.
  10. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    Actually if ~/.local/Uber Entertainment found settings will be saved here.
    I do know that if this directory not found game will store them in media/user.

    I'm already asked devs about that, but don't get any answer yet.
  11. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    Moved both directories, no dice. Drat!
  12. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    Although the one in media/user did come back after the run...
  13. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    Other "interesting" messages-

    Code:
    8094 20:22:52.772409 W | PID: 8096 | 8123 20:22:52.722266 [8096:8123:ERROR:tcp_listen_socket.cc(72)] Could not bind socket to 127.0.0.1:9999
    8094 20:22:52.772423 W | PID: 8096 | 8120 20:22:52.759668 [8096:8120:WARNING:proxy_service.cc(888)] PAC support disabled because there is no system implementation
    Did a netstat and did see that port 9999 was connected. What the... ?

    Took a scan of "ps ax | grep Cohe" and found 49 instances of the CoherentUI_Host.bin process. They're all sleeping, and I can't seem to kill them, either - with a -9 or -15. What is Coherent doing to my system?!
  14. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    This port used by Coherent for communication with it's debugger.

    49 processes is pretty strange. I'm totally sure you can kill them all without problem, but they might keep here as zombie until you kill main process.

    Actually there should be about 8 Coherent processes per game instance and they should exit properly with game.
    shootall likes this.
  15. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    Correct; 8 process per game. Did get them all killed, as well as anokandi_m, which was also using port 9999. Thought I had it licked, double-checked that port 9999 was no longer in use, but no-go. Still locks up, and when I close the window, the Coherent processes remain. Argh. Nothing has changed on my system recently that I know of.
  16. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    Argh. Still no-go with build 55430. On the initial screen, when I hit Accept, it locks up but the background sound continues.

    Freshly downloaded (not doing Steam). Any clues?

    Code:
    [14:44:13.990] INFO Log file /home/me/.local/Uber Entertainment/Planetary
    Annihilation/log/PA-14-44-13.990.txt opened
    [14:44:13.990] INFO Loaded 0 mods
    [14:44:14.285] INFO GL_VENDOR: NVIDIA Corporation
    [14:44:14.286] INFO GL_RENDERER: GeForce GTX 660/PCIe/SSE2
    [14:44:14.286] INFO GL_VERSION: 4.3.0 NVIDIA 325.08
    [14:44:14.286] INFO GL_SHADING_LANGUAGE_VERSION: 4.30 NVIDIA via Cg compiler
    [14:44:14.286] INFO Gamma correct pipeline enabled.
    [14:44:14.334] INFO Configure, 1280 by 720
    [14:44:14.371] INFO build version 55430
    [14:44:14.371] INFO Coherent content root: "coui://ui/"
    [14:44:14.371] INFO Coherent host dir: "/home/me/src/PA/PA/host"
    [14:44:14.371] INFO Coherent local store: "/home/me/.local/Uber
    Entertainment/Planetary Annihilation/localstore"
    /home/me/src/PA/PA/host/CoherentUI_Host: line 4: ldconfig: command not
    found
    /home/me/src/PA/PA/host/CoherentUI_Host: line 19: ldconfig: command not
    found
    Could not find libudev.
    [14:44:14.452] ERROR reconItemLayerFromString encountered unknown value:
    [WL_Underwater]
    
    [14:44:14.453] ERROR reconItemLayerFromString encountered unknown value:
    [WL_Underwater]
    
    [14:44:14.456] ERROR reconItemLayerFromString encountered unknown value:
    [WL_Underwater]
    
    [14:44:14.457] ERROR reconItemLayerFromString encountered unknown value:
    [WL_Underwater]
    
    [14:44:14.458] ERROR reconItemLayerFromString encountered unknown value:
    [WL_Underwater]
    
    [14:44:14.459] ERROR reconItemLayerFromString encountered unknown value:
    [WL_Underwater]
    
    [14:44:14.460] ERROR reconItemLayerFromString encountered unknown value:
    [WL_Underwater]
    
    [14:44:14.460] ERROR reconItemLayerFromString encountered unknown value:
    [WL_Underwater]
    
    [14:44:14.461] ERROR reconItemLayerFromString encountered unknown value:
    [WL_Underwater]
    
    [14901:14901:ERROR:resource_bundle.cc(528)] Failed to load
    /home/me/src/PA/PA/host/ui_resources_100_percent.pak
    Some features may not be available.
    [14:44:14.471] ERROR multiple models in spec for Air Factory have nav
    structures, this is unexpected.
    [14:44:14.473] ERROR multiple models in spec for Advanced Air Factory have nav
    structures, this is unexpected.
    [14:44:14.475] ERROR /pa/units/air/bomber_torpedo/bomber_torpedo.papa: open
    failed
    [14:44:14.522] INFO {{FMOD}} fmod buffer size 5
    [14:44:14.540] INFO Setting graphics to high
    14889 20:44:14.541356 W | PID: 14891 | 14891 20:44:14.457613
    [14891:14891:ERROR:resource_bundle.cc(528)] Failed to load
    /home/me/src/PA/PA/host/ui_resources_100_percent.pak
    Some features may not be available.
    [14:44:14.549] INFO SystemReady
    14889 20:44:14.572186 W | PID: 14891 | 14915 20:44:14.548685
    [14891:14915:WARNING:proxy_service.cc(888)] PAC support disabled because there
    is no system implementation
    [14924:14924:INFO:renderer_main.cc(215)] Running without renderer sandbox
    [14927:14927:INFO:renderer_main.cc(215)] Running without renderer sandbox
    [14932:14932:INFO:renderer_main.cc(215)] Running without renderer sandbox
    [14930:14930:INFO:renderer_main.cc(215)] Running without renderer sandbox
    14889 20:44:14.716776 W | PID: 14891 | 14891 20:44:14.710007
    [14891:14891:ERROR:(0)] Failed to load
    /home/me/src/PA/PA/host/ui_resources_100_percent.pak
    Some features may not be available.
    14889 20:44:15.040122 W | PID: 14891 | 14891 20:44:15.033058 Requesting resource
    read for coui://ui/mods/ui_mod_list.js with internal id 44 reported FAIL
    14889 20:44:15.072137 W | PID: 14891 | 14891 20:44:15.056881 Requesting resource
    read for coui://ui/mods/ui_mod_list.js with internal id 45 reported FAIL
    14889 20:44:15.111925 W | PID: 14891 | 14891 20:44:15.109475 Requesting resource
    read for coui://ui/mods/ui_mod_list.js with internal id 83 reported FAIL
    setOption medium
    [14:44:15.317] INFO Setting graphics to medium
    setOption medium
    setOption medium
    setOption medium
    setOption off
    setOption off
    [14:44:15.318] INFO Setting camera mouse pan speed to 1x
    [14:44:15.318] INFO Setting camera key pan speed to 1x
    [14:44:15.318] INFO Setting camera zoom speed to 1x
    [14:44:15.318] INFO Setting camera edge scroll to off (no mouse lock)
    [14:44:15.318] INFO Setting planet pole lock to off
    [14:44:15.359] INFO resetGameState
    [14:44:15.359] INFO Mouse constraint cleared.
    [14:44:15.359] INFO setMusic /Music/Main_Menu_Music
    
  17. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    Haven't been able to play PA for weeks. Hope the next update resolves this. :(
  18. eeyrjmr

    eeyrjmr Member

    Messages:
    137
    Likes Received:
    13
    yup something has changed recently

    first of all the CoherentUI_Host script is assuming too many things, like "ldconfig" is actually in the current users path variable (by default most linux distributions do not add /sbin to the users path)

    equally ldconfig -p will actually return a number of locations for udev since it will pop up in a couple of places YET the code is assuming a single entry is return THUS it bombs out of the test -e

    Code:
    #!/bin/bash
    
    function check_udev {
        /sbin/ldconfig -p | grep libudev.so.0 > /dev/null
        return $?
    }
    
    
    HOST_DIR=`dirname "$0"`
    if [ -n "$LD_LIBRARY_PATH" ]
    then
        export LD_LIBRARY_PATH="$HOST_DIR":$LD_LIBRARY_PATH
    else
        export LD_LIBRARY_PATH="$HOST_DIR"
    fi
    
    if ! (check_udev || [ -e "$HOST_DIR/libudev.so.0" ] )
    then
        UDEV_SO=$(/sbin/ldconfig -p | grep libudev.so.1 | cut -d' ' -f4 | head -1)
        if [ -e "$UDEV_SO" ]
        then
            ln -s "$UDEV_SO" "$HOST_DIR/libudev.so.0"
        else
            echo "Could not find libudev."
        fi
    fi
    
    exec -a "$0" "$HOST_DIR/CoherentUI_Host.bin" "$@"
    
    This fixes the script to test and link for libudev.


    PA still won't run for me however,

    Code:
    ./PA: /usr/lib64/libcurl.so.4: no version information available (required by ./PA)
    Not sure exactly what is wrong here, does my system have too high a version?

    and then there are tonnes of errors.
  19. tbacav

    tbacav Member

    Messages:
    52
    Likes Received:
    27
    Standalone still more or less works on Gentoo/~amd64/gnome3/nvidia with proprietary drivers as of build 56310.

    Still requires libudev hack.
  20. arm2thecore

    arm2thecore Active Member

    Messages:
    198
    Likes Received:
    132
    Not for me it doesn't. Initial screen freezes when pressing "Accept." The Coherent debugger also can't seem to make a connection with the Coherent_UI process or something; pressing "Go" just makes it freeze up too. At the point of hitting the Accept button, strace indicates that it's going into some kind of looping on select():

    Code:
    select(5, [4], NULL, NULL, {0, 0})      = 0 (Timeout)
    
    I don't know what's going on. I just wanna play this game again. :(

Share This Page