[Linux] Persistent buffer mapping disabled?

Discussion in 'Mac and Linux' started by n00n, September 2, 2014.

  1. n00n

    n00n Active Member

    Messages:
    345
    Likes Received:
    210
    Now that there are options to toggle this feature, if Uber could tell us what issue to look out for we could provide feedback on which drivers/hardware to re-enable this on?


    I'm using the latest (v340.32) NVIDIA proprietary drivers (on a GTX Titan) and it doesn't seem to effect the stability of the game.
  2. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    Great that you can test it because ability to test if something got fixed it's was main reason why I requested option to toggle rendering features. :)

    According to developers it's caused crashes with Nvidia drivers on Linux.
  3. jorgenpt

    jorgenpt Uber Programmer Uber Alumni

    Messages:
    164
    Likes Received:
    390
    It was disabled because it caused blatant rendering artifacts (planet surface will look obviously wrong) on what at the time was the most recent (beta?) NVIDIA drivers for Linux. One of the main motivations for me to add the --gl-force-enable-capabilities option was to get some feedback on whether or not the persistent buffers work reliably now, since it gives a nice perf boost.

    I'd be interested to hear feedback from various Linux users on various hardware when running the game with --gl-force-enable-capabilities="Persistent buffer mapping" -- as well as the output of this command:
    Code:
    glxinfo | grep GL_ARB_buffer_storage
    Please post hardware, driver version, output of the glxinfo command, and if PA a) crashed, b) ran, but planets rendered weirdly, or c) worked fine.

    Thanks!
    SXX likes this.
  4. gerii

    gerii Member

    Messages:
    90
    Likes Received:
    32
    Looked good to me on both my GPUs. Driver 343.13 for Nvidia and latest git for Intel (Mesa 10.4.0-devel).
    Code:
    /opt/Planetary Annihilation/stable > glxinfo | grep GL_ARB_buffer_storage
      GL_ARB_blend_func_extended, GL_ARB_buffer_storage,
      GL_ARB_blend_func_extended, GL_ARB_buffer_storage,
    /opt/Planetary Annihilation/stable > primusrun glxinfo | grep GL_ARB_buffer_storage
      GL_ARB_buffer_storage, GL_ARB_clear_buffer_object, GL_ARB_clear_texture,
      GL_ARB_buffer_storage, GL_ARB_clear_buffer_object, GL_ARB_clear_texture,
  5. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,329
    Likes Received:
    2,126
    Tried it on Kubuntu 14.04 with stock drivers on Intel HD4000 (Intel(R) Core(TM) i7-3632QM CPU).
    Code:
    [23:20:10.043] INFO OpenGL Vendor: Intel Open Source Technology Center
    [23:20:10.043] INFO OpenGL Renderer: Mesa DRI Intel(R) Ivybridge Mobile
    [23:20:10.043] INFO OpenGL Version: 3.3 (Core Profile) Mesa 10.1.3
    [23:20:10.043] INFO OpenGL Shader Language Version: 3.30
    [23:20:10.043] INFO Vendor flag set to Intel.
    [23:20:10.043] INFO Supported rasterizer capabilities: Gamma correct pipeline, Ranged mapping, Advanced instancing, Advanced shaders, Persistent buffer mapping
    
    It crashes when it tries to display the planets. That is, just after the loading screen has disappeared.
    In case it helps, the crash ID was bp-23316035-a09c-45dc-bd88-d26232140903, but I've attached the dump as well.

    Output of "glxinfo | grep GL_ARB_buffer_storage" is empty.

    Attached Files:

  6. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,329
    Likes Received:
    2,126
    Also tried it on Kubuntu 14.04 with stock drivers on GeForce GT 650M (using nvidia-prime)
    Code:
    [23:29:49.887] INFO OpenGL Vendor: NVIDIA Corporation
    [23:29:49.887] INFO OpenGL Renderer: GeForce GT 650M/PCIe/SSE2
    [23:29:49.887] INFO OpenGL Version: 4.4.0 NVIDIA 331.38
    [23:29:49.887] INFO OpenGL Shader Language Version: 4.40 NVIDIA via Cg compiler
    [23:29:49.887] INFO Vendor flag set to NVidia
    [23:29:49.887] INFO Supported rasterizer capabilities: Gamma correct pipeline, Ranged mapping, Advanced instancing, Advanced shaders, Compute shaders, Persistent buffer mapping
    It's looks good to me. No crashes and no artifacts at all.

    Output of "glxinfo | grep GL_ARB_buffer_storage" is:
    Code:
      GL_ARB_blend_func_extended, GL_ARB_buffer_storage,
      GL_ARB_blend_func_extended, GL_ARB_buffer_storage,
    I did have a crash after twenty minutes of play, but I'm pretty sure it's unrelated and a bug in nvidia-prime itself. The desktop (and therefore game) freezes. I can only get it going again by using Ctrl+Alt+F1 and then Ctrl+Alt+F7. That kicks everything in action again. Doing so crashed PA though. I've attached the dmp just in case, but like I said, I'm pretty sure it's a nvidia-prime bug and not a bug in PA. The desktop freezes also occur when not playing PA.

    Attached Files:

  7. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    DeathByDenim likes this.
  8. n00n

    n00n Active Member

    Messages:
    345
    Likes Received:
    210
    Code:
    [15:57:37.878] INFO OpenGL Vendor: NVIDIA Corporation
    [15:57:37.878] INFO OpenGL Renderer: GeForce GTX TITAN/PCIe/SSE2
    [15:57:37.878] INFO OpenGL Version: 4.4.0 NVIDIA 340.32
    [15:57:37.878] INFO OpenGL Shader Language Version: 4.40 NVIDIA via Cg compiler
    Code:
      GL_ARB_blend_func_extended, GL_ARB_buffer_storage,
      GL_ARB_blend_func_extended, GL_ARB_buffer_storage,
    
    All three? I tested in the system editor with all planet types.
    • I had a crash but PA's not yet stable on my system and following runs with the same planet system didn't crash (so I don't think it's related to enabling this option, but I'll attach the dump anyway).
    • There where a couple of very minor artifacts e.g. down ice planet cracks. But these are not caused by enabling the option.
    • So really, there's no noticeable change and it worked fine. ;)

    Attached Files:

    Last edited: September 3, 2014

Share This Page