Linux FOSS drivers issues and fixes

Discussion in 'Mac and Linux' started by SXX, August 27, 2013.

  1. mjog

    mjog New Member

    Messages:
    15
    Likes Received:
    2
    Well, beat myself to it. I'm getting some lovely textures now under Mesa 9.2 after converting all shaders to version 130, removing GL_EXT_gpu_shader4 and renaming texelFetch2D to just texelFetch. I'll update the PA issue.

    Can even see where the metal is! Woo!
    SXX likes this.
  2. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    Wow I renamed functions, but don't think we can just rename function. Are you totally sure it's they're doing the same?
  3. mjog

    mjog New Member

    Messages:
    15
    Likes Received:
    2
    Haha, oh well. Trust ATI and Nvidia to do the wrong thing! :D
  4. mjog

    mjog New Member

    Messages:
    15
    Likes Received:
    2
    Yeah, after a quick comparison of the description of the two functions, in the GL 1.3 spec and in the EXT_gpu_shader4 docs, they seem at least roughly equivalent. Makes sense I guess - if the extension was popular then there's no reason to not standardise it. Note I am a complete GL newb however, so YMMV. :)
  5. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    Also actually it's quite interesting to see if this fix will work for OS X dudes with AMD video. o_O
  6. mjog

    mjog New Member

    Messages:
    15
    Likes Received:
    2
    Are they having similar problems? If it is the same thing, you should totally make a note in FS#2427 that it's not just us free software hippies having the problem! :)
  7. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    Obviously at least everyone with Intel graphics have this problem on Windows.

    Also I uploaded fixed shaders here. :)

    PS: Oh crap, now tropic planets might have 20M of polygons again. :eek:

    Attached Files:

    Last edited: October 8, 2013
  8. mjog

    mjog New Member

    Messages:
    15
    Likes Received:
    2
    Sweet! Also note I posted fixes for the remaining two shaders in FS#2428. With those in place, I'm now getting no GLSL errors at all.
  9. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    As long as I understand prelight_virtual_vizmip.fs and prelight_virtual_vizpage.fs are not used in game.
    They are here broken for long long time.
  10. mjog

    mjog New Member

    Messages:
    15
    Likes Received:
    2
    Oh right, no problem then. Nice to have zarro boogs in the error log, though - makes it easier to spot actual problems.
  11. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    Agree, if you understand what for these shaders are used let me know. :)

    Currently on open drivers only two problems left: shadows glitches and white/black lines bug. :)
    Actually I know that on Windows black lines are happen because of anisotropic filtering, but I can't manage to fix it on R600g.
  12. geometrics

    geometrics New Member

    Messages:
    11
    Likes Received:
    0
    SXX I just saw this, just wondering, as by no means a computer savvy person, what do I actually need to DO with those shaders? On Mac OSX. You linked it from another place saying it may be the solution to all the graphical problems on Mac.
  13. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    First you need to open directory where game installed. I don't sure how you can do that if you installed it using dmg, but if you using Steam try that:
    Open Library -> Right click on "Planetary Annihilation" -> Properties -> Local Files tab -> Click on "Browse Local Content" button.
    Then in game directory you need to open media/shaders/ subdirectory and copy all shaders I uploaded here.

    If you not using Steam probably you need to wait before somebody else do that.

    It's probably not fix all graphical problems, but most likely trees/rocks and metal spots should appear.
  14. aeonsim

    aeonsim Active Member

    Messages:
    195
    Likes Received:
    42
    Those shaders definitely do NOT help on OSX, they make the planet disappear entirely...

    Screen Shot 2013-10-08 at 7.00.20 PM.png
  15. aeonsim

    aeonsim Active Member

    Messages:
    195
    Likes Received:
    42
    If your interested the attached log files show the differences between the standard & SXX shaders, note none of the SXX ones appear to compile due to the error "ERROR: 0:1: '' : version '130' is not supported".

    Attached Files:

  16. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    Thank you for testing, i'll try to find out.

    PS: This happen because looks like this card only support OpenGL 2.1 under OS X. :eek:
    Last edited: October 8, 2013
  17. aeonsim

    aeonsim Active Member

    Messages:
    195
    Likes Received:
    42
    Hi @SXX here are the corrected Shaders for OSX, thanks for explaining how to fix them:

    These fix the issue with Objects (trees/rocks) not being rendered.

    If you want to try the Shaders then on OSX follow these instructions:
    If using Steam select the game > rclick > properties > Local files > Browse local files.


    Rclick on the PA.app and select show content then navigate > Contents > Resources > Shaders.
    Copy the original shaders into a new folder somewhere, then in the PA Resources > Shaders > copy the unzipped shaders from the fix into the folder and overwrite the existing shaders.

    To revert simply overwrite with the copy of the original shaders you made.

    For the Direct download version of PA for OSX it works the same you just have to manually find where you placed the PA.app bundle.

    Fixed Planet: Lava planet issue appears to be a separate bug.
    Screen Shot 2013-10-08 at 8.35.53 PM.png

    Attached Files:

    Last edited: October 9, 2013
  18. geometrics

    geometrics New Member

    Messages:
    11
    Likes Received:
    0
    Thanks so much for this @aeonsim It's fixed it! Now the game actually doesn't look atrocious. Also thanks to @SXX for the help too. Now if only someone would teach me how to actually play this game. I don't understand the importance of metal and energy, but that's for another discussion i'm sure.
  19. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,326
    Likes Received:
    2,118
  20. christopherschultz

    christopherschultz New Member

    Messages:
    11
    Likes Received:
    0
    Stupid question: where are the corrected shaders? I'd like to give them a try but it looks like there is no link... am I missing something? Thanks!

Share This Page