[INFO] How To Open Replay Links

Discussion in 'Videos And Replays!' started by cptconundrum, May 1, 2014.

  1. lulamae

    lulamae Well-Known Member

    Messages:
    632
    Likes Received:
    292
    Thanks. I did that and I got the program request box from Firefox the first time (without going further), and now it just goes to the replay info page without opening PA. (after making the edit offered by @zgrssd) Any thoughts?
  2. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,330
    Likes Received:
    2,120
    Hmm, I don't have Windows myself, so I can't test anything, but if you go to a page such as http://pastats.com/replay/13832514543727382754 you just get some info about the replay and PA won't start automatically? Does anything happen if you click on the startpa:// link on that page?
  3. lulamae

    lulamae Well-Known Member

    Messages:
    632
    Likes Received:
    292
    The startpa:// link redirects me to the page in your post.

    That is, when I start at the game data/chart page http://pastats.com/chart?gameId=341969 , the Launch Replay in PA link is http://pastats.com/replay/13832514543727382754 . Clicking that link sends me to the page you linked to - http://pastats.com/replay/13832514543727382754
    And that's where it ends.

    I also tried doing this through Internet Explorer and after being redirected I received an error message ~unable to open helper application/Protocol specified in address is not valid.

    I verified that the script written by @cptconundrum in this thread did write to the registry.
  4. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,330
    Likes Received:
    2,120
    Are you sure you typed the path correctly in the .reg file? Also taking care to use double \\ as path separators? Could you post the content of the .reg file you made?
  5. lulamae

    lulamae Well-Known Member

    Messages:
    632
    Likes Received:
    292
    This is what I have in my .reg file

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\startpa]
    @="URL:startpa protocoll"
    "URL Protocol"=""
    
    [HKEY_CLASSES_ROOT\Wow6432Node\startpa\shell]
    
    [HKEY_CLASSES_ROOT\Wow6432Node\startpa\shell\open]
    
    [HKEY_CLASSES_ROOT\Wow6432Node\startpa\shell\open\command]
    @="C:\\Games\\Planetary Annihilation\\PA.exe --uioptions \"%1\""
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\startpa]
    @=""
    "URL Protocol"=""
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\startpa\shell]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\startpa\shell\open]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\startpa\shell\open\command]
    @="C:\\Games\\Planetary Annihilation\\PA.exe --uioptions \"%1\""

    What I did not see is any reference to "
    @="URL:startpa protocoll"" in the registry
  6. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,330
    Likes Received:
    2,120
    Hmm, yeah. That looks ok as far as I can tell. I hope somebody that does run Windows comes along and can help you.
    In the mean time, you can copy the number part from links such as http://pastats.com/replay/13832514543727382754 in PA itself under Replays.

    Kind of odd though. I would have expected "C:\\Games\\Planetary\ Annihilation\\PA.exe" instead of "C:\\Games\\Planetary Annihilation\\PA.exe". That is, a '\' before the space between Planetary and Annihilation. But it's like that in all of the posts, so I suppose it's correct.
    lulamae likes this.
  7. cola_colin

    cola_colin Moderator Alumni

    Messages:
    12,080
    Likes Received:
    16,221
    The path is in quotes.
    Not sure what the problem is though. Either the registry entry has some annoying syntax error or the browser in question decided to do its own thing.
  8. lulamae

    lulamae Well-Known Member

    Messages:
    632
    Likes Received:
    292
  9. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,330
    Likes Received:
    2,120
    Yeah, but --uioptions is included in the quotes if you look at the .reg file itself. What I meant to say was I would have expected
    Code:
    @="C:\\Games\\Planetary\ Annihilation\\PA.exe --uioptions \"%1\""
  10. lulamae

    lulamae Well-Known Member

    Messages:
    632
    Likes Received:
    292
    Neither Firefox nor IE will work for me. Below are the entries in my registry.


    ROOT
    [​IMG]

    LOCAL MACHINE
    [​IMG]
  11. cola_colin

    cola_colin Moderator Alumni

    Messages:
    12,080
    Likes Received:
    16,221
    is that path to PA.exe correct? Normal PA installations have a \stable\ or \pte\ inside of it:[​IMG]
    lulamae likes this.
  12. lulamae

    lulamae Well-Known Member

    Messages:
    632
    Likes Received:
    292
    Ding-ding-ding-ding. We have a winner!

    I was using the path to PALauncher (oops)

    Now a question of curiosity.... This PA.exe is only 325 KB

    But there are 2 other PA.exe in

    C:\Games\Planetary Annihilation\Planetary Annihilation\stable\bin_x86 at 5,743 KB
    and
    C:\Games\Planetary Annihilation\Planetary Annihilation\stable\bin_x64 at 7,333 KB

    I take it that the PA file in the STABLE folder will start of of the ones above depending on your OS?

    Thanks for your help.
  13. cola_colin

    cola_colin Moderator Alumni

    Messages:
    12,080
    Likes Received:
    16,221
    yep
  14. wpmarshall

    wpmarshall Planetary Moderator

    Messages:
    1,832
    Likes Received:
    2,914
    Since Titans, I've been unable to open replay links - I have PA Stats Online mod enabled and here is my reg file;

    "
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Wow6432Node\startpa]
    @=""
    "URL Protocol"=""

    [HKEY_CLASSES_ROOT\Wow6432Node\startpa\shell]

    [HKEY_CLASSES_ROOT\Wow6432Node\startpa\shell\open]

    [HKEY_CLASSES_ROOT\Wow6432Node\startpa\shell\open\command]
    @="C:\\Program Files (x86)\\Steam\\SteamApps\\common\\Planetary Annihilation Titans\\PA.exe --uioptions \"%1\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\startpa]
    @=""
    "URL Protocol"=""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\startpa\shell]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\startpa\shell\open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\startpa\shell\open\command]
    @="C:\\Program Files (x86)\\Steam\\SteamApps\\common\\Planetary Annihilation Titans\\PA.exe --uioptions \"%1\""

    "

    (Obviously without the top and bottom quote marks)

    When I try and open replay links it still only gives me options to open PA as if it were still being run through the Uber launcher i.e. c/games/uber/pa/stable/pa sort of thing.
    I should also mention that today I completely removed PA from my computer and reinstalled just Titans via steam as I had about 3 different PA's installed in various places.

    Would much appreciate any help anyone may be able to give :D
  15. tracert

    tracert Member

    Messages:
    52
    Likes Received:
    13

    I'm on Ubuntu and I've been getting this bug. Even if I type in a replay ID it doesn't work. Others are reporting it too:

    https://forums.uberent.com/threads/rel-pa-stats-86422.50690/page-43#post-1109128
  16. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,330
    Likes Received:
    2,120
    I'm not entirely sure what you mean by "When I try and open replay links it still only gives me options to open PA as if it were still being run through the Uber launcher". I suspect you mean it's not running from inside of Steam? That is, no auto-login or Steam Overlay and such. If that's the case, then try it like this:
    Code:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\startpa\shell\open\command]
    @="C:\Path\To\Steam.exe -applaunch 386070 --uioptions \"%1\""
    I can't test if that works due to lack of access to Windows, but supposedly it does. And I think 386070 is the app ID for PA: Titans, but you may have to double check that. You may still run into the trouble that @tracert mentioned though, which is that PA tries to load the replay but then fails.
  17. wpmarshall

    wpmarshall Planetary Moderator

    Messages:
    1,832
    Likes Received:
    2,914
    See attached image.
    Despite that path no longer existing, and after editing the pastats.reg file.

    (the PA Titans one is there because I 'added an option' - it doesn't appear by default. )

    Attached Files:

  18. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,330
    Likes Received:
    2,120
    Ah, I see what you mean now. Well, that's odd. Can you use the registry editor to check if the registry actually has the correct values? (<WinKey> + R and then type "regedit")

    If they are correct, you can also use the registry editor to search for the string "Planetary Annihilation Launcher" to see where else if occurs. It has to pull that value from somewhere...
  19. cola_colin

    cola_colin Moderator Alumni

    Messages:
    12,080
    Likes Received:
    16,221
    I dunno owhat marshalls problem is, but I now modified the PA Stats UI mod to load titan replays, before they kept failing. The downside is that this means non titan replays will fail to load. But who would want to watch those anyway.
    And if you do, use the replayid I guess.
    Last edited: September 8, 2015
    Quitch likes this.
  20. wpmarshall

    wpmarshall Planetary Moderator

    Messages:
    1,832
    Likes Received:
    2,914
    I've successfully got PA titans to launch with the reg file and replay links, bnut then it just sits on the main menu and doesn't do anything else. When it launches PA I have to type in my Uber password, following that no replay opens.

Share This Page