Hotfix Build 83796 with Release Build 82834 is live!

Discussion in 'Planetary Annihilation General Discussion' started by mkrater, June 10, 2015.

  1. wondible

    wondible Post Master General

    Messages:
    3,279
    Likes Received:
    2,084
    GW: the 'regular' non-easy star systems templates are never used.

    In gw_galaxy, the variable StarSystemTemplates is initialized to the normal templates; when the generator runs it changes the value of this variable to the easy templates if set. However, StarSystemTemplates exists in a scope which never expires; the initial assignment runs only on scene startup, and the first pass through the generator routine is always on the lowest difficulty due to the initial dropdown value.
    Quitch likes this.
  2. jables

    jables Uber Employee

    Messages:
    812
    Likes Received:
    5,537
    OP update:

    Hotfix build 83796 - 7/7/15
    - Fix for large number of "Cilantro" errors
    thetrophysystem, n00n and cdrkf like this.
  3. cdrkf

    cdrkf Post Master General

    Messages:
    5,721
    Likes Received:
    4,793
    Hi jables, welcome back! How was the honeymoon? :)
  4. ViolentMind

    ViolentMind Active Member

    Messages:
    394
    Likes Received:
    186
    What exactly are "Cilantro" errors?
    Planktum likes this.
  5. cola_colin

    cola_colin Moderator Alumni

    Messages:
    12,074
    Likes Received:
    16,221
    Coherent UI crashes
  6. Alpha2546

    Alpha2546 Post Master General

    Messages:
    977
    Likes Received:
    1,561
    It seems that naval hotkeys are broken. You can't quickly build naval units through the standard hotkey system. Repro is using naval hotkeys when trying to build with naval fabricators.

    Also I have the commander under ctrl group 1 and sometime I spam that button. What happens is that it won't reselect the commander again and can't reselect. Repro is put commander under ctrl group 1 -> double tap 1 -> click with your mouse on terrain to deselect the commander (left click somewhere) and double tab 1 again to reselect him. You'll notice that you won't select him.
  7. andrehsu

    andrehsu Active Member

    Messages:
    366
    Likes Received:
    120
    Why not just use alt+c (Default Binding)
  8. Alpha2546

    Alpha2546 Post Master General

    Messages:
    977
    Likes Received:
    1,561
    Because I didn't knew . I'll try it out :) ! Then again it won't fix the bug. Thanks though
  9. andrehsu

    andrehsu Active Member

    Messages:
    366
    Likes Received:
    120
    The fast foward button seems to be broken in the chronocam. Yes I used --nomods.
    Planktum likes this.
  10. Quitch

    Quitch Post Master General

    Messages:
    5,306
    Likes Received:
    5,995
    The fast forward button is broken for spectators and in replays. It works for players.
    Planktum and cola_colin like this.
  11. MrTBSC

    MrTBSC Post Master General

    Messages:
    4,843
    Likes Received:
    1,818
    started the game and experienced
    stuttering of ... everything ... starting with the mouse jumping arround and visuals from loading symbols as well as a jumping of the sphere when navigating the planet .... basicly the game was unplayable :(
    no mods been used ...

    EDIT:

    so unistalled the game completely .. installed it again - same issues :(
    appearantly windoewed helps with that ... but still ...






    so to summerise ... stuttering of everything in full view
    and consistent disconects after 10 ish minutes ... HALP!!!!




    edit 2:


    starting PA with kompatibility mode win 7 seemed to help with the disconect ...

    overall performance however is pretty poor
    Last edited: July 14, 2015
  12. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,326
    Likes Received:
    2,118
    Does it only stutter when moving the mouse or is it unrelated?
  13. MrTBSC

    MrTBSC Post Master General

    Messages:
    4,843
    Likes Received:
    1,818
    there are a number of things stuttering even without moving the mouse or navigating the planet ..
    so basicaly everything that is in motion stutters and/or blinks

    edit:
    got a cilantro error now




    edit 2:

    i think i can savely say this is currently like the worst build performancewise for me ...
    even with low settings i get lag with significant delay and input delay ...

    i managed to not disconnect through starting the game as admin and compatibility mode win 7
    as well as fixing the motionstuttering with windowed mode but that is not preferable ..
    Last edited: July 14, 2015
  14. mkrater

    mkrater Uber Alumni

    Messages:
    1,349
    Likes Received:
    1,830
    We're still working with Coherent for "cilantro" errors. If you get this error, please follow the instructions here to send in your crash file: http://support.uberent.com/kb/faq.php?id=18
  15. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,326
    Likes Received:
    2,118
    I've been playing Galactic War, and I found something odd with saves. I've taken pains to run the entire Galactic War with --nomods, so that it is definitely not caused by mods.

    Initial scenario:
    I have a subcommander helping me out and am in a battle versus two AIs. I have beaten one of the AIs and my subcommander is still alive.

    Then I save the game and when resuming, the following happens:
    I wait around for about 20 seconds and suddenly the remaining AI commander will self destruct. The game will simply continue from this point with just me and my subcommander. The game won't end either.

    Here is the save:
    https://www.dropbox.com/s/o0s057hsmwe22qc/GWSave.zip?dl=1
    mkrater likes this.
  16. mkrater

    mkrater Uber Alumni

    Messages:
    1,349
    Likes Received:
    1,830
    Thank you for testing and posting this information. I'll have someone review it and check it out. :)
  17. Remy561

    Remy561 Post Master General

    Messages:
    1,016
    Likes Received:
    641
    This has been that way for 1.5 months already, look at 4:05.


    For me the game did end though ;)

    Original bugreport here: https://forums.uberent.com/threads/pte-build-82821-pte-is-up-now.68951/page-4#post-1089956
  18. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,326
    Likes Received:
    2,118
    Ah, I only started playing GW recently again. :)
    I think the fact that I have a subcommander prevented the game from ending. You don't seem to have one in that video there.
    Remy561 likes this.
  19. Remy561

    Remy561 Post Master General

    Messages:
    1,016
    Likes Received:
    641
    Yeah I bet the game thought you had to kill your friend as well then, have you tried to nuke him? :p
  20. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,326
    Likes Received:
    2,118
    Sadly I didn't have the super weapons card. :)
    Remy561 likes this.

Share This Page