Game will not display on my screen - says "Invalid Format"

Discussion in 'Monday Night Combat PC Feedback and Issues' started by ricefrog, January 2, 2011.

  1. ricefrog

    ricefrog New Member

    Likes Received:
    [EDIT: Issue resolved, solution described in second post.]

    Hi, I was gifted a Steam copy of MNC by a friend over the holidays.

    My computer's display is my LCD television.

    When I try to run the game, I see the splash screen, then the screen goes blank (which is normal for a game that is changing the resolution). After that I hear the sound of the game running, but the television just displays the error "Invalid Format."

    Here are details about the rig, things I have already tried, and some questions at the end:

    PC running Win7 ultimate N 64 bit.
    Graphics card is an ATI Radeon HD 4800 series
    Television is a Sony Bravia S Series, here is a link to the full specs etc: ... 1665381955
    My computer is connected to the TV via the VGA input, not HDMI.

    I have run full-screen video games on this system before without display problems, including Starcraft 2, Section 8, and Street Fighter 4. If I can't solve this problem I can install my Steam copies of TF2 or L4D as a test, although the downloads will take hours so I haven't yet.

    My theory is that the problem is the resolution settings of MNC.

    I am not an expert on the interaction between my software, video card, and television with respect to resolution, but I have had some weird issues with resolutions just on the windows OS itself. Most resolutions at least display, but many of them don't magnify to fullscreen in a way that preserves the aspect ratio. A few give the "invalid display" error just like MNC.

    I can perform a test of every available resolution in the windows menu to make a list if necessary, but here are some ones I have tried:

    800x600 - displays
    1024x768 - displays
    1280x720 - Invalid Format error
    1360x768 - displays (this is the one I use for my OS)
    1600x122 - Invalid Format error

    I settled on running my computer at 1360x768, because it zooms to fullscreen on the TV well.

    Since I cannot go into the game and navigate the menu system, I did some googling and saw people talking about editing "the ini files" to change resolution without entering the game. But there weren't too many details, such as what files or what values.

    I found the following file:
    C:\Program Files (x86)\Steam\steamapps\common\monday night combat\HostileGame\Config\HostileEngine.ini

    I changed the ResX and ResY in both the [SystemSettings] and [SystemSettingsEditor] blocks to a variety of resolutions including 800x600, 1024x768 and 1360x768 which all should work on my TV. This did not change the behavior at all.

    Unfortunately my TV has the bad feature of not telling me what resolution is trying to be used when it shows invalid format. So I can't tell if the game is actually trying with the different resolution or not after I edit the .ini file.

    So obviously if anybody knows exactly what my problem is, do tell. I hope it's not "This game doesn't work on your setup"!

    But even if you don't here are some questions you could answer to help my investigation:

    Is that the correct .ini file for changing the resolution?
    Am I editing the correct values in the file? Do I have to change both blocks or just SystemSettings?
    Is it necessary to take other steps such as restart Steam after editing the file? (Didn't help the one time I tried it).
    What is the list of supported resolutions for MNC that I can safely put in the .ini file?
    What is the game's default resolution?
    Are there display settings other than resolution that might be causing problems? For example screen refresh rate?
    Any other ideas of things I could try?

    Thanks for any help you can provide. Was hanging out with the friend that gifted it to me over the weekend and had to tell him the bad news when he asked if I was having fun with it.
    Last edited: January 2, 2011
  2. ricefrog

    ricefrog New Member

    Likes Received:
    OK I think I figured it out.

    There's a second copy of some of the ini files here:
    C:\Users\[my user]\Documents\My Games\UnrealEngine3\HostileGame\Config

    And those are the files read by MNC, not the ones I was editing.

    So now the game displays and I'll just have to experiment to see if I can get something widescreen that the game and TV can concur on.
  3. bgolus

    bgolus Uber Alumni

    Likes Received:
    Did some digging on your tv, it does not support 1280x720 resolution when using the VGA input.
    Check page 41, it has a list of all of the resolutions the TV will accept, as well as a bit of warning text that says anything that doesn't exactly match those resolutions will not be displayed. It's very peculiar that the TV doesn't do 1280x720 at all, but will do 1280x768.

    Normally I would say you should turn on GPU scaling to force a specific resolution and have your video card scale it to fit, but unfortunately this doesn't work with VGA connections. My understanding of how the Unreal Engine deals with resolutions is you can define what resolution to run, but the refresh rate is determined by your video card's settings.

    Try this page for setting up your video card to have the correct resolutions for your tv.
    They're using an HDMI connection in the example, but I would guess this does work for VGA.
  4. ricefrog

    ricefrog New Member

    Likes Received:
    Ben, thanks for the post above. That was above and beyond the call, and more than I expected when I posted.

    I feel bad I haven't done my part and followed up on your effort, but you see, I have this little problem...

    I have spent every frickin minute of my free time playing MNC since the second I had it running.

    I haven't been like this since Tribes 2, nearly a decade ago.

Share This Page