Crash on login [Solved]

Discussion in 'Support!' started by Skaltum, August 31, 2015.

  1. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    When I login to playfab through the game client it will crash.

    Single player works (when not launching through steam and thereby logging in)
    Failing the login does not crash the game.
    Shorty after a successful login the game crashes.

    Windows 10
    Tried:
    reinstalling, validating cache, removing all mods, running in win8 compatibility mode. running as administrator removed extra monitors, removed sound devices.

    with mods:
    http://crashes.uberent.com/report/index/bp-24de7a89-fff1-48a4-b413-464d52150831

    without mods:
    http://crashes.uberent.com/report/index/bp-087595ec-742f-4cb9-a76f-e32582150831

    as administrator without mods:
    http://crashes.uberent.com/report/index/bp-11f25d13-9058-4a95-90c7-4c2c62150831
  2. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,121
    It seems to be crashing when accessing the network. Could you check to see if you have any software from the following list?
    http://steamcommunity.com/app/233250/discussions/2/558751813508748383/

    Also try running the SFC tool that comes with Windows: https://support.microsoft.com/en-us/kb/929833
    That will check all of your system files for bad stuff.
    Skaltum likes this.
  3. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    The crash only happens on successful logins though, it will detect a failed login (incorrect pw) without problems.

    SFC came up clean.
    I installed no software from that list since my last successful game (last week).
  4. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,121
    Odd. As a test, could you try disabling your firewall and virus scanner to see if they are doing something weird? Sometimes PA gets mistaken as a browser because it uses an UI based on Chromium.

    If that doesn't work, can you upload the whole PA log from a crash after logging in? Preferably without mods.

    Also your answer regarding the list of software, do you mean you don't have any software from that list installed at all or did you mean that you do have software from that list installed, but it's been there always?
    Skaltum likes this.
  5. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    Tried with windows firewall and windows defender turned off. That is the only antivirus stuff installed.
    Same thing.

    Attached Files:

  6. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    gDebugger (intercepts opengl api calls) and uBlock origins (browser plugin for blocking ads) fall in the list. Neither of those are currently running.
  7. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,121
    Yeah, that should probably be fine. You've tried pretty much every trick already, but have you also already tried the clean boot?
    http://support.microsoft.com/kb/929135/

    And just judging from the crash reports in your DxDiag.txt, I would almost think that CoherentUI64.dll somehow got damaged or interfered with, but you've already verified the integrity of the game cache, so that should be fine. Tricky...

    Actually, one other thing that you may also want to try is to just try resetting PA configuration altogether. You can do so by going to the directory "%LOCALAPPDATA%\Uber Entertainment\". You can just copy-paste that in the address bar of Explorer. Then rename the "Planetary Annihilation" directory to "Planetary Annihilation.bak" while PA is closed. Starting PA will then make a completely fresh configuration for you. If you manage to log in without crashing, then apparently something really bad was going on in your config. If it doesn't help, you can just delete the newly created "Planetary Annihilation" directory and rename the "Planetary Annihilation.bak" back to "Planetary Annihilation".
    Skaltum likes this.
  8. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    Same thing happened in both steps.

    Attached Files:

  9. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,121
    My goodness. Sorry that this is being such a hassle for you...

    Hmm, PA-2015-08-31_222621.txt doesn't seem to contain a crash log. However, both contain a line like this:
    Code:
    [22:26:27.906] INFO [COUI] PID: 10636 | 5372 20:26:27.876647 [10636:5372:ERROR:audio_low_latency_output_win.cc(244)] Bailing out due to non-perfect timing.
    But the first PA log a few posts ago doesn't contain that, so I am not sure if that even tells us anything.

    I'm kind of running low on ideas, but one more thing you could try is to try the UberLauncher instead of Steam. It will results in a 2 GB download though.
    You can get the UberLauncher here: https://store.uberent.com/download/pa

    By the way, the game used to run fine for you in Windows 10 until last week, right? Can you remember anything that's changed in the last week?
    Skaltum likes this.
  10. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    I might have quit that one as soon as I noticed it had gone unresponsive.

    I've been running PA directly from the installation folder. Steam/SteamApps/common/Planetary Annihilation/bin_x64/PA.exe

    Besides the occasional crash during replays and the windows 10 game launch noise it was fine.
    I removed the Windows.old directory using the disk cleanup utility. I don't remember if that was before or after the crashes started happening.
    Other than some application updates, no more changes to the system.

    Tried the uberlauncher. It has the same symptoms as launching through steam. When I sign in and press play in the uber launcher it locks up and dies before I hit the main menu. When I launch in offline mode I can play single player, the game crashes if I sign in through the main menu.

    Attached:
    000136.txt, game lauched in offline mode, crashed when logged in from main menu
    000258.txt, game lauched while signed in with the uber launcher.

    I'm VERY grateful for you being here helping me out. Thanks

    Attached Files:

  11. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,121
    Could you run the following command from the Windows command-line? (Press <WinKey>+R and type "cmd")
    Code:
    tasklist /FO csv > "%userprofile%\desktop\tasks.csv"
    It will create a file on your desktop called tasks.csv that will contain all of the processes currently running on your computer. I'm trying to figure out if any of those could possibly do Bad Stuff.

    I have never seen your problem before, you are quite unique, so thanks for you patience. :)
  12. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    This is with a clean boot

    Attached Files:

  13. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,121
    Well... every single process in there looks ok. I'm going over your crash logs again and most of the time it seems to be in IPC, which is the inter-process communication part. So I am wondering if reducing the number of processes would have any effect. Could you try starting PA like this?
    Code:
    PA --coherent-options="--single-process"
  14. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    No change :(
    Made a typo in one of them I see. Space instead of dash in --single-process

    Attached Files:

  15. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,121
    I'm afraid that was my last idea. Well, short of doing a clean install of Windows 10...

    Maybe @mkrater can redirect an engineer to this thread that might have ideas and take a look at the crash logs.
    mkrater likes this.
  16. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    Looks like i'll be doing a fresh windows install.
  17. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,121
    Yeah, I even downloaded the free Win10 Virtualbox image from Microsoft that is meant for testing the Edge browser. Just to try and see if I could get the same trouble as you by installing some of the programs you have. Unfortunately, Virtualbox only support up to OpenGL 2 apparently so it won't run PA... :(

    So sorry about that...

    Oh, a thought did occur. Do you by any chance have really funky UTF-16 characters in your display name (or Steam name). PA has had some trouble with that (though not the crashes you have). If you do, could you try setting your Steam name to a simple alphanumerical name?
  18. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    <-- My steam name, so no. Also haven't changed it recently.
  19. Skaltum

    Skaltum New Member

    Messages:
    22
    Likes Received:
    5
    So, i just reinstalled windows. And the same crash happens.

    Attached Files:

  20. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,121
    Wow, I didn't expect that to not work...

    Could you try out the PTE that's currently up? It contains a lot of fixes. I suspect you'll get the same crash as there is nothing similar in the list though. So when you crash, could you make a post in the PTE thread as multiple devs check that out for bug reports with a PA log and the DxDiag.txt?

    PTE usage instructions in case you need them: http://exodusesports.com/guides/exodus-explains-planetary-annihilation-pte/

Share This Page