Clicking Gets Stuck

Discussion in 'Support!' started by brianpurkiss, June 11, 2014.

  1. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
    Couldn't find this reported on the bug tracker or on the forum. But I keep on getting my mouse stuck.

    When putting up a build queue, the mouse gets stuck and won't unclick. I can't use esc key, I can't right click, I can't middle click. I can't do anything. I have to force quit PA, and if I'm playing Galactic War on the PTE, then I can't reconnect to my match and lose all the progress.

    Anyone else experience this?
    sookrispy likes this.
  2. thetdawg3191

    thetdawg3191 Active Member

    Messages:
    260
    Likes Received:
    74
    i can second this. box selection is especially prevalent.
    brianpurkiss likes this.
  3. wondible

    wondible Post Master General

    Messages:
    3,299
    Likes Received:
    2,089
    Are you playing PTE? It's a Coherent UI crash. My report along with my next two posts in that thread: https://forums.uberent.com/threads/pte-stream-67099-main.60577/#post-941347
    brianpurkiss likes this.
  4. mot9001

    mot9001 Well-Known Member

    Messages:
    833
    Likes Received:
    650
    Im having all sorts of problems with my mouse. Selecting, making blueprints from the cursor, the sensitivity of the zooming not being constand and the 2nd screen sometimes interfering and sometimes not. I think its partially my mouse because i have an state of the art microsoft bluetrack mouse wich seems to suck ***.
    brianpurkiss likes this.
  5. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
    Yes it is the PTE build.

    I really hope Uber fixes it real soon.
  6. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
    Still happening on the current PTE build with no mods installed.

    This bug is game breaking, I really hope Uber fixes it soon.
  7. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
    This bug is still in the new live build.

    I can't complete a match because my cursor gets stuck in the middle of a build queue every game.
  8. wondible

    wondible Post Master General

    Messages:
    3,299
    Likes Received:
    2,089
    brianpurkiss likes this.
  9. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
  10. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    I do not think problems on Linux and Mac are related, but it's still looks like problem appear after latest changes in how UI bars work.
  11. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
    As long as we're getting closer to discovering the root of the problem, I'm happy.

    @SXX, if you need me to do any testing or anything, let me know.

    I really want to get back to playing PA. :)
  12. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    So, you get crashes in 100% of times? Any chance you can try to run PA with "--software-ui"?
    Though I have no idea how to do that on Mac... :)
  13. wondible

    wondible Post Master General

    Messages:
    3,299
    Likes Received:
    2,089
    Open Terminal.app, assuming UberLauncher.

    Code:
    ~/Library/Application Support/Uber Entertainment/Planetary Annihilation/data/streams/stable/PA.app/Contents/MacOS/PA --software-ui
    Made things worse for me - UI elements not being erased, and then the entire client crashed.
  14. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    This is weird. There is clearly issue with stability on Linux, but I can play full game just fine with "--software-ui" and it's only rarely crash... :(
  15. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
  16. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
    Yeah. It gets stuck for me 100% of the time I'm playing. It just takes different amounts of time before it crashes. Haven't noticed any issues while spectating, but that's kinda different.
  17. selfavenger

    selfavenger Active Member

    Messages:
    128
    Likes Received:
    78
    I experienced for the first time as well today also Brian. Was during Galactic War and happened right after I paused the game.
  18. wondible

    wondible Post Master General

    Messages:
    3,299
    Likes Received:
    2,089
    I also watched an AI game yesterday without error.
  19. popededi

    popededi Well-Known Member

    Messages:
    784
    Likes Received:
    553
    Not sure if related, but WASD is sometimes unresponsive when I have units selected. If I unselect it's responsive again.
  20. RushSecond

    RushSecond New Member

    Messages:
    22
    Likes Received:
    17
    Hello everyone, this is my first post. I've been lurking a little while, but in this thread I think I found an opportunity to be helpful.

    I've been having the same issue; sometimes when I try to queue up a building, it sometimes gets stuck and won't build, and the structure gets stuck on the cursor. The first few times I saw this, I just press esc a bunch and generally flailed around in panic, causing the UI to crash completely.

    However, I found a bit of a workaround to help avoid a full crash. As soon as you notice a stuck building, just press/release shift once and the UI will start responding again. You can then hold shift to queue up buildings if that's what you wanted. I've played several dozen GW games doing this and not crashed my UI once.

    Of course, this is still a bug that Uber should fix, but using this shift method should allow everyone to keep playing the game in the meantime.

Share This Page