58678: If it's crashing, please vote

Discussion in 'Support!' started by garat, December 18, 2013.

?

Are you crashing 100% of the time in the latest build? If yes, what's your OS?

Poll closed December 19, 2013.
  1. OS/X 10.9

    54.1%
  2. OS/X 10.7 or 10.8

    16.2%
  3. Windows 7 or 8/8.1 64-bit

    10.8%
  4. Windows 7 or 8/8.1 32-bit

    5.4%
  5. Windows Vista 64-bit

    2.7%
  6. Windows Vista 32-bit

    0 vote(s)
    0.0%
  7. Linux (Any)

    10.8%
  1. garat

    garat Cat Herder Uber Alumni

    Messages:
    3,344
    Likes Received:
    5,376
    Trying to collect some information. IF the latest build is crashing for you every time, please indicate your OS via vote. If you're just getting occasional crashes (such as periodic system related crashes), please do not vote, but you can provide details in a thread reply.

    And please, only vote if this is NEW behavior as of 58678. If you were already crashing 100% of the time, we need to find that out, but we're specifically trying to track down who got impacted by what in the latest patch.
  2. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
    100% of the time when I try and join a game on latest version of OS X.

    I can mess with settings and other stuff just fine. It crashes when I join a game. I even have an option to reconnect when I restart PA.

    Happy to provide any additional info.

    Edit: no mods
    Last edited: December 18, 2013
  3. mrosseel

    mrosseel New Member

    Messages:
    18
    Likes Received:
    8
    crashes 100% (clean install no mods) on Mac 10.9, see the crashfile attached. Hope it gets fixed soon because I want to play :)

    Attached Files:

    brianpurkiss likes this.
  4. rendrick

    rendrick New Member

    Messages:
    11
    Likes Received:
    0
    Same behavior here. If you hit Reconnect, it simply crashes the game again.
  5. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    Ok I'm got this crash and currently I think it's related to those shaders:
    Code:
    ./shadowmap_batch_adv.vs
    ./shadowmap_tex_batch_adv.vs
    ./shadowmap_tex_impostor_batch_adv.vs
    They not work due to this problem:
    Code:
    0:1(10): error: GLSL 1.40 is not supported. Supported versions are: 1.10, 1.20, 1.30, and 1.00 ES
    Currently it's looks like PA use OpenGL 3.0 core profile on Linux even when 3.1 available:
    Code:
    [23:32:37.024] INFO OpenGL Renderer: Gallium 0.4 on AMD CAYMAN
    [23:32:37.024] INFO OpenGL Version: 3.0 Mesa 10.1.0-devel (git-37c24e6 saucy-oibaf-ppa)
    [23:32:37.024] INFO OpenGL Shader Language Version: 1.30
    As result Mesa shader compiler fail to compile GLSL 1.4 shaders which belongs to OpenGL 3.1.

    Actually I can overrride core profile like that:
    Code:
    MESA_GL_VERSION_OVERRIDE=3.1 MESA_GLSL_VERSION_OVERRIDE=140 ./PA
    But then Coherent start return ton of GL errors: :(
    Code:
    Some features may not be available.
    5816 19:35:42.407073 W | PID: 5821 | 5821 19:35:42.392745 [5821:5821:ERROR:(0)] InitializeSandbox() called with multiple threads in process gpu-process
    5816 19:35:42.425809 W | PID: 5821 | 5821 19:35:42.420307 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C0940D2B3A040000]GL ERROR :GL_INVALID_ENUM : glBufferData: <- error from previous GL command
    5816 19:35:42.425884 W | PID: 5821 | 5821 19:35:42.425251 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C008362B3A040000]GL ERROR :GL_INVALID_ENUM : glBufferData: <- error from previous GL command
    5816 19:35:42.440320 W | PID: 5821 | 5821 19:35:42.427204 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C0C0012B3A040000]GL ERROR :GL_INVALID_ENUM : glBufferData: <- error from previous GL command
    5816 19:35:42.440402 W | PID: 5821 | 5821 19:35:42.429351 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C07C4A2B3A040000]GL ERROR :GL_INVALID_ENUM : glBufferData: <- error from previous GL command
    5816 19:35:42.440436 W | PID: 5821 | 5821 19:35:42.431143 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_ENUM : glBufferData: <- error from previous GL command
    5816 19:35:42.459329 W | PID: 5821 | 5821 19:35:42.440919 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_ENUM : glBufferData: <- error from previous GL command
    5816 19:35:42.460111 W | PID: 5821 | 5821 19:35:42.450474 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_ENUM : glBufferData: <- error from previous GL command
    5816 19:35:42.460226 W | PID: 5821 | 5821 19:35:42.457259 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_ENUM : glBufferData: <- error from previous GL command
    Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
    5816 19:35:42.640404 W | PID: 5821 | 5821 19:35:42.623892 Requesting resource read for coui://ui/mods/ui_mod_list.js with internal id 44 reported FAIL
    5816 19:35:42.656975 W | PID: 5821 | 5821 19:35:42.640592 Requesting resource read for coui://ui/mods/ui_mod_list.js with internal id 45 reported FAIL
    5816 19:35:42.657074 W | PID: 5821 | 5821 19:35:42.640619 Requesting resource read for coui://ui/mods/ui_mod_list.js with internal id 46 reported FAIL
    5816 19:35:42.707587 W | PID: 5821 | 5821 19:35:42.701658 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_OPERATION : glTexImage2D: <- error from previous GL command
    5816 19:35:42.708119 W | PID: 5821 | 5821 19:35:42.704213 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_OPERATION : glTexImage2D: <- error from previous GL command
    5816 19:35:42.741340 W | PID: 5821 | 5821 19:35:42.738053 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_OPERATION : glTexImage2D: <- error from previous GL command
    5816 19:35:42.757802 W | PID: 5821 | 5821 19:35:42.743591 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_OPERATION : glTexImage2D: <- error from previous GL command
    setOption custom
    [23:35:42.791] INFO Setting graphics to custom
    setOption medium
    setOption medium
    setOption off
    setOption on
    [23:35:42.791] INFO Setting camera mouse pan speed to 1x
    [23:35:42.791] INFO Setting camera key pan speed to 1x
    [23:35:42.791] INFO Setting camera zoom speed to 1x
    [23:35:42.791] INFO Setting camera friction to 2.5x
    [23:35:42.791] INFO Setting camera edge scroll to off (no mouse lock)
    [23:35:42.792] INFO Setting planet pole lock to off
    [23:35:42.824] INFO resetGameState
    [23:35:42.824] INFO Mouse constraint cleared.
    [23:35:42.824] INFO setMusic /Music/Main_Menu_Music
    5816 19:35:42.874501 W | PID: 5821 | 5821 19:35:42.867251 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_ENUM : BackFramebuffer::Create: <- error from previous GL command
    5816 19:35:42.874591 W | PID: 5821 | 5821 19:35:42.867732 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::ctor: was unhandled
    5816 19:35:42.874614 W | PID: 5821 | 5821 19:35:42.867742 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::dtor: <- error from previous GL command
    5816 19:35:42.874669 W | PID: 5821 | 5821 19:35:42.867757 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::dtor: was unhandled
    5816 19:35:42.874702 W | PID: 5821 | 5821 19:35:42.867763 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::ctor: was unhandled
    5816 19:35:42.874733 W | PID: 5821 | 5821 19:35:42.867775 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::dtor: was unhandled
    5816 19:35:42.874763 W | PID: 5821 | 5821 19:35:42.867796 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::ctor: was unhandled
    5816 19:35:42.874793 W | PID: 5821 | 5821 19:35:42.868391 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::dtor: was unhandled
    5816 19:35:42.874822 W | PID: 5821 | 5821 19:35:42.868400 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::ctor: was unhandled
    5816 19:35:42.874850 W | PID: 5821 | 5821 19:35:42.868415 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::dtor: <- error from previous GL command
    5816 19:35:42.874877 W | PID: 5821 | 5821 19:35:42.868428 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::dtor: was unhandled
    5816 19:35:42.874905 W | PID: 5821 | 5821 19:35:42.868441 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::ctor: was unhandled
    5816 19:35:42.874933 W | PID: 5821 | 5821 19:35:42.868451 [5821:5821:ERROR:(0)] [GroupMarkerNotSet(crbug.com/242999)!:C06C642B3A040000]GL ERROR :GL_INVALID_OPERATION : ScopedFrameBufferBinder::dtor: was unhandled
    5816 19:35:42.967746 W | PID: 5821 | 5821 19:35:42.955026 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_OPERATION : glTexImage2D: <- error from previous GL command
    5816 19:35:43.058247 W | PID: 5821 | 5821 19:35:43.048663 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_OPERATION : glTexImage2D: <- error from previous GL command
    5816 19:35:44.857733 W | PID: 5821 | 5821 19:35:44.842132 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_OPERATION : glTexImage2D: <- error from previous GL command
    5816 19:35:47.850505 W | PID: 5821 | 5821 19:35:47.836176 [5821:5821:ERROR:(0)] [.ChromiumCompositor]GL ERROR :GL_INVALID_OPERATION : glTexImage2D: <- error from previous GL command
    And for some reason "--software-ui" flag not working for me in this build. :(

    PS: I guess that problem on Mac might be related to same shaders.
    cola_colin and Raevn like this.
  6. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
  7. harpo9999

    harpo9999 New Member

    Messages:
    3
    Likes Received:
    0
    100% of the time when trying to start, ahave not seen the menu in 58678 yet
  8. abubaba

    abubaba Well-Known Member

    Messages:
    501
    Likes Received:
    385
    If it matters, I crashed on loading a new system with the new patch until I updated my video card drivers. (Never happened before.)

    Windows 7 64-bit with Nvidia.
  9. shiwanabe

    shiwanabe Member

    Messages:
    82
    Likes Received:
    32
    Mac OSX 10.8.5
    Consistant crashes on new system load or 'Build' in system editor.
    System editor crash report attached.

    Attached Files:

  10. nicelifebs

    nicelifebs New Member

    Messages:
    1
    Likes Received:
    0
    I have the same problem with my system. OS X 10.8.5 and NVIDIA GeForce GT 650M. Too bad I just bought the game because it was on the Humble Bundle store and it looked amazing. Murphy's Law strikes again ;)
    I wait till the hot fix is ready.

    Attached Files:

  11. chrisedwards1994

    chrisedwards1994 New Member

    Messages:
    1
    Likes Received:
    0
    MacBook Pro retina 8Gb Ram i7 OS X 10.9

    Can open game and adjust settings crashes 100% of the time when attempting to join games, have reconnect option but repeats crash.
  12. WarriorServent

    WarriorServent Member

    Messages:
    54
    Likes Received:
    33
    First off; it crashes every time I try to load a planet when using Windows 7 on a 64 Bit system. Secondly, I just love the fact the the community is already trying to help Uber fix the problem, you guys are awesome!!
  13. Ragmash

    Ragmash New Member

    Messages:
    22
    Likes Received:
    20
    Windows 7 32bit. 4GB Ram. NVIDIA GeForce 8800 GTS 512

    New Behavior: Crashes 100% of time when attempting to begin a match, whether online or v. AI. Will also crash 100% of the time while attempting to Preview a planet in the System Generator.

    Thank you Uber for being seriously awesome. :)
    Last edited: December 19, 2013
  14. bunnybones

    bunnybones New Member

    Messages:
    1
    Likes Received:
    0
    Sorry guys,
    Voted for 10.8 when I should have voted 10.9.
    Anyways, eat, sleep and get us up and running again.
    Thanks for your awesomeness.
  15. garat

    garat Cat Herder Uber Alumni

    Messages:
    3,344
    Likes Received:
    5,376
    Mac guys - problem should be fixed next built.

    Windows folks - I'm curious if any of you have no sound device or sound device disabled? If so, it may be fixed as well. If not, uncertain.

    Linux guys - we've fixed a few potential linux crashes as well with the above fixes, plus a few random bug fixes that may address other crashes that are Linux specific.
    pownie and SXX like this.
  16. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,812
    Great, can't wait to test it!

    Can you please test it on some Intel hardware with new open source drivers, e.g Intel laptop with Ubuntu 13.10? Mesa and it's shader compiler just way more strict in terms of GLSL standards than Nvidia/AMD drivers.

    I just want back to testing a lot so I'm really want to see PA use proper OpenGL core profile. :oops:
  17. rendrick

    rendrick New Member

    Messages:
    11
    Likes Received:
    0
    Any word on when the next build will drop?
  18. brianpurkiss

    brianpurkiss Post Master General

    Messages:
    7,879
    Likes Received:
    7,438
    It's already here! Was pushed yesterday.
  19. mrosseel

    mrosseel New Member

    Messages:
    18
    Likes Received:
    8
    working great, good job!
  20. thehighestcommander

    thehighestcommander New Member

    Messages:
    2
    Likes Received:
    0
    I dont crash but freeze up about 5 min into game OSX 10.9

Share This Page