System edit derp (slightly funny). Help pls

Discussion in 'Planetary Annihilation General Discussion' started by Nicb1, December 22, 2014.

  1. Nicb1

    Nicb1 Post Master General

    Messages:
    1,010
    Likes Received:
    1,286
    Hey guys.
    Today I decided to give the system editor a shot due to all the new awesome sounding features that have been added recently. I was hoping to modify the metal planet. Well letsa just say things didnt go according to plan. I will show you guys what happened in a bunch of pics below.

    When you click advanced edit and confirm a few changes, this happens.
    [​IMG]
    (Was wondering "what the hell happened here")

    So I proceededd to realign as much stuff as I could, but unfortunately it still looked a tad derpy. Also got rid of one of the poles and replaced it with this.
    [​IMG]
    (i've changed it quite a bit since this screenshot)

    So I load up the system in a singleplayer game just to test it out (this is where the real fun happens)
    Unfortunately none of my changes were applied to the metal planet :(
    [​IMG]

    I decided to look over the rest of the planets in my system. And I think I found out where those metal planet parts disappeared to earlier.
    [​IMG]
    (Honestly dont know what to think of this) All the csg waas removed on this moon "mountains etc" and it was replaced with the missing metal planet parts.


    So in the end I have no idea what happened. I'm assuming that this is all a bug, but if any of you know how to fix this slightly hilarious issue please let me know.

    Sorry for the long post.
    guest1, cdrkf and stuart98 like this.
  2. aapl2

    aapl2 Active Member

    Messages:
    260
    Likes Received:
    175
    metal planet with the lava looks great.
    Zaphys, cola_colin, stuart98 and 3 others like this.
  3. Nicb1

    Nicb1 Post Master General

    Messages:
    1,010
    Likes Received:
    1,286
    I know :)
    Was really hoping that it would work out, but unfortunately in the single player all the changes were removed and it looked like any other metal planet :(

    EDIT:
    Definitely one of my fave combos though. Second on the list being lava and Ice biomes mixed.
  4. squishypon3

    squishypon3 Post Master General

    Messages:
    7,971
    Likes Received:
    4,356
    I'm quite particular to moon with metal planet bits. :)
  5. christer1966

    christer1966 Member

    Messages:
    61
    Likes Received:
    55
    I love the lava in the fissures. I wish there were more of them on lava planets and that the lava lakes ad that coloured lava.
  6. g0hstreaper

    g0hstreaper Well-Known Member

    Messages:
    686
    Likes Received:
    553
    Did you try turning it on then off?
    ace902902, stuart98 and squishypon3 like this.
  7. Nicb1

    Nicb1 Post Master General

    Messages:
    1,010
    Likes Received:
    1,286
    This was my end result with the metal planet, but unfortunately it always changes to the default metal planet when I load up a game.
    [​IMG]
  8. ef32

    ef32 Well-Known Member

    Messages:
    446
    Likes Received:
    454
    I have another thing to report. I made a cool system with 9 planets, but nobody would join my lobby, because system was too big (I know that because if I change to 4 or less planets, it fills up instantly).
    So I decided to make mini version of my awesome system. I had some csg edited planets, and some normal ones there. I deleted 3 planets I liked least, realigned the rest and saved. Looked cool in editor.

    I launched AI game and what I saw that 3 of smaller planets had same CSGs that only one of them should have had (hand placed ice csgs on generated desert and earth planets), and all three of those had metal spots flying in orbit, apparently, it was metal from one of the bigger planets I had in this system.
  9. superouman

    superouman Post Master General

    Messages:
    1,006
    Likes Received:
    1,139
    How did you remove the pole caps? i wasn't able to do so.
  10. Nicb1

    Nicb1 Post Master General

    Messages:
    1,010
    Likes Received:
    1,286
    I just selected the parts which made up the cap and deleted them all. Unfortunately there is no point bothering with metal planets at this point in time as a lot of weird stuff happens with them in the system editor. When I loaded the planet into a match the pole cap was there again and all the lava features I applied were not present anymore. The whole planet appears to have regenerated to default.

    But yeah basically just delete the csg's that make up the pole cap and it should fill in.
  11. wondible

    wondible Post Master General

    Messages:
    3,286
    Likes Received:
    2,084
    A lot of the metal planet stuff is explicitly placed in the planet type rather than generated by the biome generator. That stuff may not be movable.

Share This Page