[REL] [CLIENT] Fix for green planet bug

Discussion in 'Released Mods' started by dom314, February 27, 2016.

  1. dom314

    dom314 Post Master General

    Messages:
    892
    Likes Received:
    1,190
    This mod tries to fix issues with the newer AMD drivers. See here for the thread where this was reported: https://forums.uberent.com/threads/switched-to-amd-card-texture-weirdness-in-pa.69731/
    The mod seems to fix it completely for some people. but only partially for others. Thanks to the people who helped me make this by testing and such! I don't actually have an affected graphics card, so this would not be possible without them.

    Please post your graphics card version / driver version and a screen shot if you have issues, or even if it works; it will all be useful data to me :).

    This is what it looks like if you are affected:
    [​IMG]
    [​IMG]

    The partial solution looks like this:
    [​IMG]
    [​IMG]
    Installation:
    The easiest way to install this mod is through PAMM, and searching for it by name or by author.
    It's possible to install it manually, but more involved. Ask if you would prefer to do it this way.
    Last edited: February 29, 2016
    Clopse, cdrkf, cola_colin and 5 others like this.
  2. Killerkiwijuice

    Killerkiwijuice Post Master General

    Messages:
    3,878
    Likes Received:
    3,622
    affected* Kappa
    stuart98 and dom314 like this.
  3. weeberz

    weeberz New Member

    Messages:
    2
    Likes Received:
    3
    Made an account just to say thank you, this fixed the artifacting around spawns and the green tint, which made the game basically unplayable for me. Idk if the issue is related, but I still get artifacting around the edges of the Fog of War, but the green tint is what was so annoying.

    Specs:
    i5-4670k at 4.4ghz
    FuryX stock clocks
    16gb RAM
    cdrkf and dom314 like this.
  4. dom314

    dom314 Post Master General

    Messages:
    892
    Likes Received:
    1,190
    Thank you for coming along to post this. I may try to resolve the issue with the fog of war as well, though I have much less information on that. There is one other person who also has the same issue. I will make a thread in the support section and tag you in it :).

    P.S. do you have any more detailed information on which graphics card you have?
    I will soon be getting the AMD R9-390X 8GB, which will hopefully mean I can reproduce these issues!
    cdrkf likes this.
  5. gazpumped

    gazpumped New Member

    Messages:
    2
    Likes Received:
    4
    Thank you so much dude !
    I completely abandoned all hope to be able to play this game in a normal way, but now your mod fixes everything, I don't even have any artifacts.

    My config :
    Windows 8.1 64bits
    i7 920
    8Gb RAM
    AMD Radeon R9 380x 4Gb
    cdrkf, dom314 and Killerkiwijuice like this.
  6. Mirolog

    Mirolog Well-Known Member

    Messages:
    294
    Likes Received:
    405
    [​IMG]
    This actually looks cool.
    dom314 and stuart98 like this.
  7. dom314

    dom314 Post Master General

    Messages:
    892
    Likes Received:
    1,190
    GPU?
  8. stuart98

    stuart98 Post Master General

    Messages:
    6,008
    Likes Received:
    3,888
    That screen is in your OP you derp.
    dom314 likes this.
  9. weeberz

    weeberz New Member

    Messages:
    2
    Likes Received:
    3
    Yes its a Sapphire FuryX, running crimson 16.1.1 currently. Stock clocks, kept cool. dont know what else to include other than that :p
    dom314 likes this.
  10. dom314

    dom314 Post Master General

    Messages:
    892
    Likes Received:
    1,190
    Derperinoes.
  11. cdrkf

    cdrkf Post Master General

    Messages:
    5,721
    Likes Received:
    4,793
    390x is gcn 1.1, I.e. not an effected card...
    dom314 likes this.
  12. dom314

    dom314 Post Master General

    Messages:
    892
    Likes Received:
    1,190
    Oh....okay xD. Well getting a card just to repo this wasn't really the point, but that is a little unfortunate.
    cdrkf likes this.
  13. cdrkf

    cdrkf Post Master General

    Messages:
    5,721
    Likes Received:
    4,793
    It's a really good card either way :p
    dom314 likes this.
  14. j4t1nd3r

    j4t1nd3r New Member

    Messages:
    9
    Likes Received:
    3
    Gigabyte Fury X, green tint issue is fixed with this mod but I suffer from fog of war artefacts. Latest drivers, windows 10.
    dom314 likes this.
  15. cdrkf

    cdrkf Post Master General

    Messages:
    5,721
    Likes Received:
    4,793
    @wyao as you guys are working on some updates at the moment, thought I'd highlight this thread.

    @dom314 has made some serious progress on tackling the shader bug with the latest gen AMD cards.

    These changes fix the issue completely for the r9 285, 380 and 380x cards. It represents a partial fix (but still a big improvement) for Fiji based nano / fury products.

    I've performed some regression testing with the couple of machines I had to hand. I can confirm this change makes no discernable difference on a gtx 970m or r9 280 (both of which were ok to start with). I've also not noticed any performance impacts.

    Perhaps this is something that could be trialled in one of the upcoming pte builds to get wider testing feedback? I think a lot of AMD users would be happy about this change and may prove quite important if this issue is also prevalent in the upcoming Polaris architecture...
    dom314 and Nicb1 like this.
  16. silentisbutonis

    silentisbutonis New Member

    Messages:
    2
    Likes Received:
    1
    Thanks man!!! this mod resolved my problem. I'm playing in Linux. Thank you.
    dom314 likes this.
  17. dom314

    dom314 Post Master General

    Messages:
    892
    Likes Received:
    1,190
    Happy to hear that bud!

Share This Page