Playfab Port build 110552 is now live!

Discussion in 'PA: TITANS: General Discussion' started by wyao, May 24, 2018.

Thread Status:
Not open for further replies.
  1. lulamae

    lulamae Planetary Moderator

    Messages:
    794
    Likes Received:
    307
    Community server now visible again
    kelwin99 likes this.
  2. kelwin99

    kelwin99 Uber Employee

    Messages:
    39
    Likes Received:
    120
    @acesoyster Were you able to get past this screen after a reboot and re-launch? Thanks for the log file.
  3. grandhomie

    grandhomie Active Member

    Messages:
    173
    Likes Received:
    188
    I ended on the same screen after a game (post update) and after a PA restart I ended up on the main menu, as expected.
    kelwin99 likes this.
  4. kelwin99

    kelwin99 Uber Employee

    Messages:
    39
    Likes Received:
    120
    @grandhomie So you are able to play after the restart?
  5. acesoyster

    acesoyster Active Member

    Messages:
    110
    Likes Received:
    154
    Yes, I could get past it after restarting. Although it has since happened a few times from a variety of game scenes, not all of which were holodeck. I however didn't take any more logs.
    okeanos and kelwin99 like this.
  6. grandhomie

    grandhomie Active Member

    Messages:
    173
    Likes Received:
    188
    Yes, sorry I wasn't clear - all good now. Although porting my profile wiped out my user settings (I still have my friends list).
    kelwin99 likes this.
  7. n00n

    n00n Active Member

    Messages:
    345
    Likes Received:
    210
    Just launched the game for the first time after the updated. All game settings were reset to default, empty friends list. No mentioned migration so I launched the game via Steam, when attempting to log into the migration dialog box it displays the following message. "Ubernet account is linked to another PlayFab account."
  8. Quitch

    Quitch Post Master General

    Messages:
    5,776
    Likes Received:
    6,035
  9. lulamae

    lulamae Planetary Moderator

    Messages:
    794
    Likes Received:
    307
    I received some sort of notification that I can neither read nor dismiss.

    [​IMG]
    kelwin99 likes this.
  10. kelwin99

    kelwin99 Uber Employee

    Messages:
    39
    Likes Received:
    120
    Good to hear that. We have a fix for user settings not migrating properly. It will be included in the next build.
  11. kelwin99

    kelwin99 Uber Employee

    Messages:
    39
    Likes Received:
    120
    Does this persist after a restart of the game?
  12. lulamae

    lulamae Planetary Moderator

    Messages:
    794
    Likes Received:
    307
    It has since cleared and I have received functional notifications.
    kelwin99 likes this.
  13. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,125
    Hey @wyao and @kelwin99 ,

    I have been testing the new user experience after @mikeyh suggested it and he gave me a key for testing. I found that the PA client crashes and afterwards is unable to join any on-line servers. This is on Kubuntu 18.04, but may apply to other OSes as well.

    To create a clean set-up I moved all my Steam files away and also moved ~/.local/Uber Entertainment/Planetary Annihilation to a different location. That should make everything new as far as Steam and PA are concerned.

    Here's how it went for me:
    • I made a new Steam account, and plugged in the Steam key.
    • After downloading, I pressed Play in Steam and PA started up ok, showing the intro movie.
    • I pressed <Esc> to skip the movie and was presented with a migration window where it was asking for my UberId and password or gave me the option "Not right now".
    • I did not select anything because I was still thinking about what to do and after about 30 seconds PA crashed.
    • I restarted PA after the crash and the migration window did not reappear.
    • If I turn off the local server in the settings and start a AI Skirmish, PA will say "Login Accepted" but won't connect. Eventually the attempts run out and PA returns to the main menu.
    It is reproduceable by the way:
    • Go to Settings -> Game play and delete the user data and restart PA.
    • The migration screen screen pops up again.
    • Wait for a bit and PA will crash and I won't be able to play on-line.

    The only way I could get it to work as a "new" Steam user is to be fast enough and click "Not right now" on the migration screen. If I manage to do that, then on-line play works.

    Also, it is kind of weird that I get a migration screen in the first place. As a new user there shouldn't be anything to migrate, right? I was a bit puzzled by that.

    I've attached some logs:
    • The first is my first ever start of PA after getting it on Steam. It crashes here.
    • The next log is me starting PA again, but not doing anything else.
    • The last shows me trying to play a game on an Uber server and failing to connect.

    Attached Files:

    kelwin99 likes this.
  14. kelwin99

    kelwin99 Uber Employee

    Messages:
    39
    Likes Received:
    120
    @DeathByDenim Thanks for this. I will pass this info and the logs over to the engineers.
    flubbateios likes this.
  15. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,125
    By the way, I talked to mikeyh about it some more. He said "Add some exception handling around json parsing in http responses and don't assume valid json in any response. Especially in the engine. Instacrash".
    This is apparently the cause of this new-player crash.
    kelwin99 likes this.
  16. MrTBSC

    MrTBSC Post Master General

    Messages:
    4,857
    Likes Received:
    1,823
    have some locked commanders, tried delete data and restart but didn´t work ..
    i am not using steam
  17. kelwin99

    kelwin99 Uber Employee

    Messages:
    39
    Likes Received:
    120
    @MrTBSC go head and contact support@uberent.com they will be able to help you with this issue.
    flubbateios and acesoyster like this.
Thread Status:
Not open for further replies.

Share This Page