PA Won't Launch - OSX

Discussion in 'Mac and Linux' started by mushoo, June 23, 2014.

  1. mushoo

    mushoo New Member

    Messages:
    6
    Likes Received:
    0
    Latest steam version, Mac OSX 10.7.5, Mac Pro (2012) 12-core, 3.46Ghz. Radeon HD5870 (with three monitors). Problem occurs with latest version from the Uber website, as well.

    I can't get it to load at all - launching from Steam will set my status to 'playing planetary annihilation' for about 3 seconds before dropping back to 'online' status. Double clicking from the finder, it doesn't even bounce - the dock resizes for about .2 seconds and then goes on as if nothing happened (perhaps because I have a ridiculous machine running from an SSD boot disk). Trying to run the "PA" executable from the MacOS folder after viewing package contents results in the attached crash log.

    *EDIT* - The only way I was able to get that crash log at all, was to delete 'steam.txt' from within the package contents. Replacing it by verifying game cache and trying to run the "PA" executable from within the MacOS folder just takes me to Steam, which then does nothing.

    Attached Files:

    Last edited: June 23, 2014
  2. wondible

    wondible Post Master General

    Messages:
    3,299
    Likes Received:
    2,089
    You didn't mention RAM, but I can't imagine it's under spec with that machine. Crash appears to occur in video init, so it might be an OS/video card issue. Could you generate a System Information report from Steam (see OS X thread in my signature) ? Creating an item in bugtracker would be splendid, but I can put it together if you don't want to.
  3. mushoo

    mushoo New Member

    Messages:
    6
    Likes Received:
    0
    Sure thing - I've attached the system info. I yanked the 'installed applications' list out of it, because it was... extremely long. 32gb RAM, and that 21TB disk space thing is soooorta correct - I have 23.5TB worth of disk capacity, but only about 7TB free.

    I did notice that it says I'm using OpenGL 2.1, and I recall seeing other threads about needing OpenGL 3.x - I fancy myself a pretty advanced user but I'm honestly not sure how I would go about upgrading just my OpenGL version on a Mac.

    Attached Files:

  4. wondible

    wondible Post Master General

    Messages:
    3,299
    Likes Received:
    2,089
    That is interesting, because they cut off 10.6 when they went to OpenGL 3.x, so I would expect 10.7 to be good (OS X OpenGL is tied to the OS release) I'm concerned that the report puts the OpenGL compatibility with the video card section, so it may be a lack of hardware support. I got a free app in the Mac App store called OpenGL Extensions Viewer, perhaps you could see if that will be more specific?
  5. mushoo

    mushoo New Member

    Messages:
    6
    Likes Received:
    0
    Yeah, very strange indeed - I've got sort of semi-compatability up through 3.3. Anything beyond 3.3 is listed as 0% compatible. I've included a screenshot that shows the unsupported functions from v3.0 through 3.3.

    Attached Files:

  6. wondible

    wondible Post Master General

    Messages:
    3,299
    Likes Received:
    2,089
    Thanks for the bug report.

    PA#3682 - PA won't open on OSX 10.7.5
  7. wondible

    wondible Post Master General

    Messages:
    3,299
    Likes Received:
    2,089
    I'd forgotten about the Apple support chart, which I have to assume Uber has read and used when selecting which functions to use.

    https://developer.apple.com/graphicsimaging/opengl/capabilities/GLInfo_1075_Core.html

    Also, this one suggests that you could run OpenGl 4.1 (e.g. OS X 10.9), though I don't know if that would have any impact on your issue.

    http://support.apple.com/kb/HT5942
  8. mushoo

    mushoo New Member

    Messages:
    6
    Likes Received:
    0
    Yeah, sadly I can't upgrade my OS for the moment (I'm a sound editor, working on a games project for the next few months). The editing software I use can be... very finicky about OS upgrades, and I know my current setup works well (for editing, at least). Once the project is done I plan to scurry on up to 10.9.x, but at the moment it's not a good solution for me.
  9. mons00n22

    mons00n22 New Member

    Messages:
    4
    Likes Received:
    0
    I'm having the exact same issue launching via steam on OSX with an nvidia gtx660ti. I downloaded the uber launcher however, and the game came up and runs just fine. (I would prefer steam though)
  10. mushoo

    mushoo New Member

    Messages:
    6
    Likes Received:
    0
    Where did you get the Uber Launcher? I tried using the dmg from uber directly (I cannot link it, because the forum software refuses to let me post a link) as well, but had the same problems.
  11. mons00n22

    mons00n22 New Member

    Messages:
    4
    Likes Received:
    0
    I got it from this thread:
    forums.uberent.com/threads/early-testing-os-xlauncher.57126/

    direct link to the dmg:
    setup.uberent.com/PA/OSX/UberLauncher.dmg

    I'd be really curious to see if this works for you as well. When I attempt to launch the executable straight from the command line I get the following (not sure if this helps anyone):
    Code:
    [bob @ KeplerOSX ~/StorageOSX/Games/Steam/SteamApps/common/Planetary Annihilation/PA.app/Contents/MacOS]$
    ./PA m
    [00:32:55.260] INFO SDL: Built w/ v2.0.3, linked w/ v2.0.3
    [00:32:55.260] INFO build version 67523
    [00:32:55.261] INFO Log file /Users/bob/Library/Application Support/Uber Entertainment/Planetary Annihilation/log/PA-00-32-55.261.txt opened
    [00:32:55.261] INFO delete /Users/bob/Library/Application Support/Uber Entertainment/Planetary Annihilation/log/PA-22-58-52.717.txt
    [00:32:55.261] INFO Looks like we are running via Steam
    szCmd: /bin/sh -c '"/usr/bin/open" "steam://run/233250"' &
    [00:32:55.263] INFO SteamAPI_RestartAppIfNecessary returned TRUE, exiting...
    The log just contains the above text. I'm running OSX 10.8.5.
  12. mushoo

    mushoo New Member

    Messages:
    6
    Likes Received:
    0
    Sadly, no such luck. The launcher went through and grabbed all the game files (I've now got 3 copies of this game floating around my drive!), and upon opening brought up a fully black window titled "Planetary Annihilation" which promptly crashed, taking UberLauncher with it.

    Crash log seems to be the same as before, from a cursory glance (EXC_CRASH (SIGABRT)).

    Attached Files:

Share This Page