PA on Arch Linux

Discussion in 'Mac and Linux' started by leesam, June 17, 2013.

  1. leesam

    leesam New Member

    Messages:
    12
    Likes Received:
    0
    I know Arch probably isn't high on the list of linux distro compatibility but i thought it'd be helpful to post what i'm seeing.

    I downloaded from http://uberent.com/launcher/padownloads.
    Extracted to /home/<myuser>/pa
    changed to the pa directory and ran below from terminal
    Code:
    [<myuser>@<mymachine> pa]$ ./PA
    [18:24:02.095] INFO Log file /home/<myuser>/.local/Uber Entertainment/Planetary Annihilation/log/PA-18-24-02.095.txt opened
    [18:24:02.095] INFO FILE
    [18:24:02.095] INFO S: /home/<myuser>/.local/Uber Entertainment/Planetary Annihilation/log/PA-18-23-36.347.txt
    [18:24:02.095] INFO L: /user/log/PA-18-23-36.347.txt
    [18:24:02.095] INFO FILE
    [18:24:02.095] INFO S: /home/<myuser>/.local/Uber Entertainment/Planetary Annihilation/log/PA-17-56-49.067.txt
    [18:24:02.095] INFO L: /user/log/PA-17-56-49.067.txt
    [18:24:02.095] INFO FILE
    [18:24:02.095] INFO S: /home/<myuser>/.local/Uber Entertainment/Planetary Annihilation/log/PA-18-04-53.949.txt
    [18:24:02.095] INFO L: /user/log/PA-18-04-53.949.txt
    [18:24:02.095] INFO FILE
    [18:24:02.095] INFO S: /home/<myuser>/.local/Uber Entertainment/Planetary Annihilation/log/PA-18-00-54.580.txt
    [18:24:02.095] INFO L: /user/log/PA-18-00-54.580.txt
    [18:24:02.095] INFO FILE
    [18:24:02.096] INFO S: /home/<myuser>/.local/Uber Entertainment/Planetary Annihilation/log/PA-17-43-15.492.txt
    [18:24:02.096] INFO L: /user/log/PA-17-43-15.492.txt
    [18:24:02.096] INFO FILE
    [18:24:02.096] INFO S: /home/<myuser>/.local/Uber Entertainment/Planetary Annihilation/log/PA-18-24-02.095.txt
    [18:24:02.096] INFO L: /user/log/PA-18-24-02.095.txt
    [18:24:02.096] INFO FILE
    [18:24:02.096] INFO S: /home/<myuser>/.local/Uber Entertainment/Planetary Annihilation/log/PA-18-19-17.534.txt
    [18:24:02.096] INFO L: /user/log/PA-18-19-17.534.txt
    [18:24:02.096] INFO FILE
    [18:24:02.096] INFO S: /home/<myuser>/.local/Uber Entertainment/Planetary Annihilation/log/PA-17-42-06.635.txt
    [18:24:02.096] INFO L: /user/log/PA-17-42-06.635.txt
    [18:24:02.282] INFO GL_VENDOR: ATI Technologies Inc.
    [18:24:02.282] INFO GL_RENDERER: AMD Radeon HD 7800 Series 
    [18:24:02.282] INFO GL_VERSION: 4.2.12337 Compatibility Profile Context 12.10.17
    [18:24:02.282] INFO GL_SHADING_LANGUAGE_VERSION: 4.30
    [18:24:04.155] INFO Configure, 1280 by 720
    [18:24:04.155] INFO build version 49595
    [18:24:04.155] INFO Coherent content root: "file:///home/<myuser>/pa/media/ui/"
    [18:24:04.155] INFO Coherent host dir: "/\x00h\x00o\x00m\x00e\x00/\x00n\x00i\x00c\x00k\x00/\x00p\x00a\x00/\x00h\x00o\x00s\x00t\x00/\x00"
    [18:24:04.156] INFO Coherent local store: "/\x00h\x00o\x00m\x00e\x00/\x00n\x00i\x00c\x00k\x00/\x00.\x00l\x00o\x00c\x00a\x00l\x00/\x00U\x00b\x00e\x00r\x00 \x00E\x00n\x00t\x00e\x00r\x00t\x00a\x00i\x00n\x00m\x00e\x00n\x00t\x00/\x00P\x00l\x00a\x00n\x00e\x00t\x00a\x00r\x00y\x00 \x00A\x00n\x00n\x00i\x00h\x00i\x00l\x00a\x00t\x00i\x00o\x00n\x00/\x00l\x00o\x00c\x00a\x00l\x00s\x00t\x00o\x00r\x00e\x00"
    [18:24:04.246] INFO setupViewportStack : 1
    [3862:3862:ERROR:resource_bundle.cc(578)] Failed to load /home/<myuser>/pa/host/ui_resources_100_percent.pak
    Some features may not be available.
    [3862:3862:WARNING:resource_bundle.cc(304)] locale_file_path.empty()
    [18:24:04.297] INFO {{FMOD}} fmod buffer size 5
    [18:24:04.322] INFO Setting graphics to high
    [18:24:04.356] INFO SystemReady
    [3885:3885:INFO:renderer_main.cc(220)] Running without renderer sandbox
    [3893:3893:INFO:renderer_main.cc(220)] Running without renderer sandbox
    [3896:3896:INFO:renderer_main.cc(220)] Running without renderer sandbox
    setOption medium
    [18:24:06.073] INFO Setting graphics to medium
    setOption medium
    setOption medium
    setOption medium
    [18:24:06.074] INFO Setting camera mouse pan speed to 1x
    [18:24:06.074] INFO Setting camera key pan speed to 1x
    [18:24:06.074] INFO Setting camera zoom speed to 1x
    [18:24:06.074] INFO Setting camera edge scroll to off (no mouse lock)
    [18:24:06.075] INFO Setting planet pole lock to off
    [18:24:06.132] INFO resetGameState
    [18:24:06.132] INFO Mouse constraint cleared.
    [18:24:06.132] INFO setupViewportStack : 1
    
    What i'm seeing is a window that is black and unchanging with a title of '???'. After it opens i get background ambiance noise just like when i run it from Windows 7 (same machine dual booted arch/Win7).

    After closing the window this is added to the commandline:
    Code:
    XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
          after 66 requests (66 known processed) with 0 events remaining.
    Don't know how useful this will be but i figured some info is better than no info.

    System info dump from steam:
    Code:
    Processor Information:
        Vendor:  AuthenticAMD
        Speed: 3200 Mhz
        4 logical processors
        4 physical processors
        HyperThreading:  Unsupported
        FCMOV:  Supported
        SSE2:  Supported
        SSE3:  Supported
        SSSE3:  Unsupported
        SSE4a:  Supported
        SSE41:  Unsupported
        SSE42:  Unsupported
        
    Network Information:
        Network Speed:  
        
    Operating System Version:
        "Arch Linux" (64 bit)
        Kernel Name:  Linux
        Kernel Version:  3.9.6-1-ARCH
        X Server Vendor:  The X.Org Foundation
        X Server Release:  11204000
        X Window Manager:  Openbox
        Steam Runtime Version:  steam-runtime-release-i386_2013-05-08
        
    Video Card:
        Driver:  ATI Technologies Inc. AMD Radeon HD 7800 Series 
    
        Driver Version:  4.2.12337 Compatibility Profile Context 12.10.17
        Desktop Color Depth: 24 bits per pixel
        Monitor Refresh Rate: 60 Hz
        VendorID:  0x1002
        DeviceID:  0x6819
        Number of Monitors:  1
        Number of Logical Video Cards:  1
        Primary Display Resolution:  1920 x 1080
        Desktop Resolution: 1920 x 1080
        Primary Display Size: 6.30" x 3.54"  (7.20" diag)
                                                16.0cm x 9.0cm  (18.3cm diag)
        Primary VRAM Not Detected
        
    Sound card:
        Audio device: Realtek ALC889
        
    Memory:
        RAM:  7981 Mb
        
    Miscellaneous:
        UI Language:  English
        LANG:  C
        Microphone:  Not set
        Total Hard Disk Space Available:  65639 Mb
        Largest Free Hard Disk Block:  19899 Mb
    
    Also, forgot to mention i had to install gconf because PA said it was missing libgconf-2.so.4 and i had to link /usr/lib/libudev.so.0 to /usr/lib/libudev.so.1
  2. laseek

    laseek New Member

    Messages:
    88
    Likes Received:
    0
    check dmesg -T or syslog - you'll find GPU or Coherent log messages in that.
    Check ps aux | grep -i coherentui for legacy processes & kill 'em if they're running.
    When there's not a clean exist they can hang around and it can cause PA to crash out.

    I get X errors when Coherent is still running - it handles the UI side of things.
  3. leesam

    leesam New Member

    Messages:
    12
    Likes Received:
    0
    After clearing out any Coherent processes (clean reboot) i launched and got the same output. Checked dmesg and saw these:

    Code:
    [  263.451730] CoherentUI_Host[773]: segfault at 44 ip 00007f32c2e0a51f sp 00007fff5914c630 error 4 in fglrx_dri.so[7f32c20cf000+1d9a000]
    [  264.543754] CoherentUI_Host[819]: segfault at 44 ip 00007f2149fae51f sp 00007fff96f24fa0 error 4 in fglrx_dri.so[7f2149273000+1d9a000]
    [  265.433509] CoherentUI_Host[848]: segfault at 44 ip 00007f260ca9a51f sp 00007fff6dbc9780 error 4 in fglrx_dri.so[7f260bd5f000+1d9a000]
    
  4. laseek

    laseek New Member

    Messages:
    88
    Likes Received:
    0
    Which AMD drivers are you running?
    I couldn't get PA to run on the beta drivers - just segfaults with fglrx - ended up having to use the 13.4 ones.
  5. leesam

    leesam New Member

    Messages:
    12
    Likes Received:
    0
    I have the catalyst 13.6-1 package installed. amdcccle shows:

    Driver Packaging Version: 12.10.17-130320a-154718E-ATI
    2D Driver Version: 13.10.10
    Catalystâ„¢ Control Center Version: 2.18
    RandR Version: 1.3
    OpenGL Provider: Advanced Micro Devices, Inc.
    OpenGL Renderer: AMD Radeon HD 7800 Series
    OpenGL Version: 4.2.12337 Compatibility Profile Context 12.10.17
  6. laseek

    laseek New Member

    Messages:
    88
    Likes Received:
    0
    Aye - 13.6 segfaulted for me - 13.4 worked.
    13.6 are currently beta drivers.
  7. tylerseacrest

    tylerseacrest Member

    Messages:
    56
    Likes Received:
    19
    Same here, latest amd 13.6 beta drives gives black screen while the current 13.4 non-beta drivers work wonderfully.

    Linux Mint 14 KDE
    Radeon 5870m

    Tyler Seacrest
  8. hobarrera

    hobarrera New Member

    Messages:
    28
    Likes Received:
    6
    It worked fine for me on Arch after I linked
    Code:
    /usr/lib/libudev.so.0
    to
    Code:
    /usr/lib/libudev.so
    .

    I've no idea why they're linking to such an old version of this library. Ironically, PA won't work on Debian due to requiring newer libraries.

    It would be nice to have a proper bug tracker. You know, to actually report bugs with as much technical detail as possible. (Here I am, hoping some dev will read this ;) )
  9. asgo

    asgo Member

    Messages:
    457
    Likes Received:
    21
    debian stable will work if you make a local install of newer libc6, just to use with PA.
    on the other hand, there was no need to link the libudev.so.0. ;)
    the more intricate part was getting proper graphics from the ivy bridge, newer mesa and newer kernel needed.


    bugtracker: http://pa.lennardf1989.com/Tracker/
  10. laseek

    laseek New Member

    Messages:
    88
    Likes Received:
    0
    I'm not sure it's something PA have control over - the libudev req comes from CoherentUI_Host (ldd host/CoherentUI_Host).
  11. MCXplode

    MCXplode Active Member

    Messages:
    196
    Likes Received:
    28
    Running arch with custom kernel compile 3.6.7 amd64; catalyst-total 13.4 from AUR, game runs with no dependancy problems and low cpu usage lower that win7 and I only have AMD A10-5800K with integrated graphics; I have LXDE window manager with minimal set of libs, lxde being gtk based, game installed on my solid state drive, only 2.95GB of files for OS in /root partition, /home partition 64GB PA installed there it may grow bigger thant my OS on game final release.
    when game final version is released might create custom USB3 flash stick with minimal form of Arch Linux bootable exclusively for running PA; f$#k maybe even make it boot straight to PA with no WM just bareX if possible and openGL drivers

    appears to use gtk2, cairo, asound, libGL, gdk, gconf, libgcc, pixman, dbus, xdamage, libnss, udev, pthreads, glib, atk some Xlibs and pretty much standard set of libraries.
    Working good until last build with display glitch. Now all I need is a videocard.
  12. Ralith

    Ralith Member

    Messages:
    124
    Likes Received:
    6
    Someone should put together a PA-on-a-stick USB disk image that works just like you describe. Configure it for wide hardware support and fast boots and you'd have a great lan party utility.
  13. hobarrera

    hobarrera New Member

    Messages:
    28
    Likes Received:
    6
    I've made an ArchLinux package I've posted on AUR.

    Dependency installation and symlining a missing .so file are handled there.
    You'll need to manually download the PA tarball though, since that's not publicly available.
  14. leesam

    leesam New Member

    Messages:
    12
    Likes Received:
    0
  15. Xaseron

    Xaseron New Member

    Messages:
    12
    Likes Received:
    0
    If you only get 1 FPS with the nvidia binary driver (version 325.15). Dowgrade to nvidia stable (version 319.49).
  16. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    One question, what is your hardware? Do you have SLI or multi monitor setup?
    It's quite interesting because we know that Nvidia have shared codebase across all platforms and Windows users have low FPS with Nvidia too.
  17. predator106

    predator106 New Member

    Messages:
    7
    Likes Received:
    0
    uhm sorry, you guys managed to get it to run? I'm having libcurl errors. Specifically my curl is too new.

    % ldd PA
    ./PA: /usr/lib/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./PA)
    libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007fc0e4657000)
  18. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    Make symlink to where your libcurl located, everything will work just fine. ;)
    Oops sorry, I'll check what you can do now.
  19. predator106

    predator106 New Member

    Messages:
    7
    Likes Received:
    0
    Okay looks like a fix is to even build 7.32 from curl.haxx.se/download.html (i'm a new user so can't link directly apparently..annoying) (i just did ./configure --prefix=/tmp ; make; make install), copied the /tmp/lib/libcurl.so and .so.4 to the PA dir and it fires up at least).

    apparently PA is using a deprecated var that was not in 7.24, and last present in 7.23. I'm not sure why it works though when I build 7.32...idk maybe it build with deprecated stuff and arch does not?

    p.s. these captchas really freaking suck.
  20. SXX

    SXX Post Master General

    Messages:
    6,897
    Likes Received:
    1,811
    I'm have libcurl 7.29 on Kubuntu 13.04 and it's working fine for me.

Share This Page