Nuke ammo blueprint mismatch

Discussion in 'Mod Support' started by aleiux, July 28, 2014.

  1. aleiux

    aleiux Member

    Messages:
    18
    Likes Received:
    66
    In the nuke launcher directory, (Planetary Annihilation\media\pa\units\land\nuke_launcher),
    nuke_launcher_ammo.json lists the build cost of the nuke at 86400 metal. It also lists its damage as 33000.
    This does not match up to the 32400 build cost and 11000 damage that exists in-game.

    However, there is a file called nuke_launcher_inter_ammo.json that lists the stats correctly.
    The problem is, nuke_launcher.json references nuke_launcher_ammo.json as its ammo.
    Not only that, but the only file that even references the correct file is nuke_launcher_inter_tool_weapon.json, which in turn is not referenced by any other file in the \pa directory.

    What's going on here? Am I missing something about how the files interact?
  2. wondible

    wondible Post Master General

    Messages:
    3,279
    Likes Received:
    2,084
    What makes you say that inter is being used? The listed cost (and the actual cost - I measured running from only metal storage) is the higher, and it will kill an Adv Air Factory (30k hp)
  3. aleiux

    aleiux Member

    Messages:
    18
    Likes Received:
    66
    I felt something was off considering that commanders only have 12500 hp (as listed in base_commander.json)
    meaning that if it were 33000 damage with 33000 splash, nukes would instakill commanders, unless there is some armor consideration which would explain the discrepancy.

    I do remember seeing 32400 as the build cost at some point, so it's possible that the inter files belonged to a previous build. In fact, pamatches lists the damage at 11000, but its quite likely they haven't updated in a while, since some of their other stats are off.
  4. aleiux

    aleiux Member

    Messages:
    18
    Likes Received:
    66
    Okay, so it appears that commanders have the attribute "armor_type":"AT_Commander"
    Upon further looking around, it seems that all naval, bot, air, vehicle, and structure units inherit an armor_type.

    Anyways, my confusion was a result of pamatches not updating their info, which is understandable since this most recent build changed a lot of things and was only a few days ago.
    Thanks for your help actually testing it out

Share This Page