[Linux] Status of Nvdia optimus support

Discussion in 'Mac and Linux' started by n00n, June 25, 2017.

  1. n00n

    n00n Active Member

    Messages:
    346
    Likes Received:
    205
    @JOndra91 recently commented over at GamingOnLinux that he was having issue running this game using a Intel+Nvidia optimus/bumblebee settup. So I've run some tests to check the state of things:
    • Using xf86-video-intel with "AccelMethod" "uxa":
      Works as expected.
    • Using xf86-video-intel with "AccelMethod" "sna" (the default method):
      Main menu/screen loads black. Can be fixed by forcing a redrawn with a window resize (alt+enter to toggling fullscreen).
    • Removing/without xf86-video-intel:
      Main menu/screen loads black. Can't force a redrawn & now get the following error:
      Code:
      [21:10:34.518] INFO [COUI] PID: 14892 | 14892 19:10:34.501388 [14892:14892:ERROR:render_widget_host_view_gtk_coherent.cc(289)] Unable to get backing store!

    The --software-ui command line option is required and was used for all of the above tests.
  2. JOndra91

    JOndra91 New Member

    Messages:
    2
    Likes Received:
    0
    I've started a thread on Coherent forums. Unforunately I can't post link to that thread so I will just paste path from navigation:
    Coherent Labs Forum » General » Feature Requests and Feedback » Coherent UI on Linux with Nvidia Optimus
  3. n00n

    n00n Active Member

    Messages:
    346
    Likes Received:
    205
    Then allow this guy. :)
  4. mikeyh

    mikeyh Post Master General

    Messages:
    1,954
    Likes Received:
    1,670
    Coherent UI is no longer available.

    PA is using the older 2.5.8 version of Coherent UI based on Chromium 28 which is the last major version of Coherent UI to support software rendering.

    The last major update of Coherent UI was 2.6.6 in early 2016 based on Chromium 40 with no software rendering support.

    Migrating to Coherent GT is not a simple task.
    Last edited: June 27, 2017

Share This Page