[Linux] game not start without any errors

Discussion in 'Mac and Linux' started by slav0nic, August 27, 2015.

  1. slav0nic

    slav0nic New Member

    Messages:
    5
    Likes Received:
    0
    Debian stretch(testing), radeonsi drivers,
    OpenGL version string: 3.0 Mesa 10.6.3


    Code:
    [14:30:53.922] INFO Started at 2015-08-24 14:30:53
    [14:30:53.922] INFO SDL: Built w/ v2.0.3, linked w/ v2.0.3
    Dongle firmware /home/sl/.steam/linux64/../controller_base/d0ggle.bin loaded, version 1435869091.
    [14:30:53.978] INFO Looks like we are running via Steam
    [14:30:53.979] INFO Loading mod : server_browser_show_cheat_servers
    [14:30:53.979] INFO LoadedLocalModCollection::loadLocalModCollection: Failed listDir call for "/home/sl/.local/Uber Entertainment/Planetary Annihilation/mods"; no mods will be loaded from this path
    [14:30:53.979] WARN LoadedLocalModCollection::loadLocalModCollection: Could not open /home/sl/.local/Uber Entertainment/Planetary Annihilation/mods/mods.json file; mods will not be mounted
    [14:30:53.979] INFO Client loaded 1 mods, mounted 0
    [14:30:53.979] INFO Loading mod : cheat_allow_change_vision
    [14:30:53.979] INFO Loading mod : cheat_allow_change_control
    [14:30:53.979] INFO Loading mod : cheat_allow_mod_data_updates
    [14:30:53.979] INFO Loading mod : cheat_allow_create_unit
    [14:30:53.979] INFO LoadedLocalModCollection::loadLocalModCollection: Failed listDir call for "/home/sl/.local/Uber Entertainment/Planetary Annihilation/server_mods"; no mods will be loaded from this path
    [14:30:53.979] WARN LoadedLocalModCollection::loadLocalModCollection: Could not open /home/sl/.local/Uber Entertainment/Planetary Annihilation/server_mods/mods.json file; mods will not be mounted
    [14:30:53.979] INFO build version 86422, id 2015081886422
    [14:30:53.993] INFO Log file /home/sl/.local/Uber Entertainment/Planetary Annihilation/log/PA-2015-08-24_143053.txt opened
    [14:30:53.994] INFO Starting async parallel for driver with 3 threads
    
    game exit without any errors in logs; `--software-ui` did't help
  2. sevmek

    sevmek Active Member

    Messages:
    114
    Likes Received:
    59
    Seems to me you are launching PA classic, not titans. Did you installed it with steam?
  3. slav0nic

    slav0nic New Member

    Messages:
    5
    Likes Received:
    0
    yes, i have only TITANS installed from steam

    with LIBGL_DEBUG=verbose ./PA --coherent-log-level=TRACE --gl-debug --software-ui

    i got:
    Code:
    [15:07:03.306] INFO Starting async parallel for driver with 3 threads
    libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/radeonsi_dri.so
    libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
    libGL: dlopen /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so failed (/mnt/data2/games/SteamApps/common/Planetary Annihilation Titans/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so))
    libGL: OpenDriver: trying ${ORIGIN}/dri/tls/radeonsi_dri.so
    libGL: OpenDriver: trying ${ORIGIN}/dri/radeonsi_dri.so
    libGL: dlopen ${ORIGIN}/dri/radeonsi_dri.so failed (/mnt/data2/games/SteamApps/common/Planetary Annihilation Titans/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so))
    
    any way for use system libstdc++ version?
  4. slav0nic

    slav0nic New Member

    Messages:
    5
    Likes Received:
    0
    replaced libstdc++.so.6 to system version and it started, with some resolution problems %)
  5. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,329
    Likes Received:
    2,125
    Interesting that that worked. :)
    What do you mean with resolution problems?
  6. sevmek

    sevmek Active Member

    Messages:
    114
    Likes Received:
    59
    Sry, I can't help. This is beyong my skills.
  7. slav0nic

    slav0nic New Member

    Messages:
    5
    Likes Received:
    0
    after second start via steam all looks ok

    about libstdc++.so.6, looks like radeonsi in debian builded with libstdc++.so >= 3.0.20 version, runtime version only 3.0.18
  8. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,329
    Likes Received:
    2,125
    Yeah, well, that's Debian stretch(testing) for you, eh? ;)
  9. n00n

    n00n Active Member

    Messages:
    345
    Likes Received:
    210
    Indeed. This is a known Steam issue for bleeding edge ditros.
    Last edited: August 27, 2015
  10. slav0nic

    slav0nic New Member

    Messages:
    5
    Likes Received:
    0
    n00n, tnx, but problem was with PA runtime ;)

Share This Page