Linux/Fedora25 black menu screen

Discussion in 'Mac and Linux' started by joanwa, December 1, 2016.

  1. joanwa

    joanwa New Member

    Messages:
    1
    Likes Received:
    0
    After the starting the game from Steam, I hear music but otherwise black screen. No menus anymore, only the lower right corner 'Join PA Chat, notifications and time' is seen.

    I have a RX 460 with Mesa drivers
  2. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,363
    Likes Received:
    2,144
    Can you post the PA log? You'll find it in "~/.local/Uber Entertainment/Planetary Annihilation/log".
  3. jjmf

    jjmf New Member

    Messages:
    1
    Likes Received:
    0
    I have a similar issue on Antergos with Gnome on Wayland using an intel HD4000 gpu. I worked until an update (had not played in a while).
    The log file is attached.

    Attached Files:

  4. JOndra91

    JOndra91 New Member

    Messages:
    2
    Likes Received:
    0
    I have same issue (Antergos). When I start the game, I can see loading screen which is OK, but the menu is black and not even resizing the window works (menu only flashes for a moment during resizing). Only the social bar is visible (it shows offline here because PA is not run via steam). And when I try to click on things blindly, it seems that nothing happens (from absence of audio feedback).

    Of course the black screen issue happens only with --software-ui switch. But PA doesn't work properly without --software-ui, on my laptop (with Nvidia optimus). When I use Intel graphics, everything is too dark (that's probably different bug and it affects more games). When I use Nvidia, I get image corruptions. And with both, menus don't render properly.

    Screenshot from 2017-05-01 21-42-07.png - black menu with --software-ui

    I've tried removing all mods and it didn't help. Then I tried with PA with different versions of Ubuntu (16.04, 16.10, 17.04) and it works only on 16.04. It used to work on 16.10 for me before but then it stopped working after some update (probably kernel or mesa).

    Attached Files:

Share This Page