Game crashing all day long

Discussion in 'Support!' started by loligerloler2, January 14, 2019.

  1. loligerloler2

    loligerloler2 New Member

    Messages:
    10
    Likes Received:
    2
    Hey everyone

    so this time my problem is that the game crashes about every 5-10 minutes. The pattern I resolved was that the first, initial crash "appeared" at the ~15 minutes mark. The only way I can close the game is by waiting until it stops answering and the little window: "PA.exe has stopped working" pops up. From there I click "close the programm" and then "cancel". This is literally the only way to close the game.
    Atfer the first crash and rejoining the game the gap between each crash is about 5-10 mins max.
    I have tried reinstalling the game. Didn't work.
    I have tried verifying game cache. Didn't work.
    I have tried disabling every single mod. Didn't work. (So it's definitely not the mods fault)
    I have searched the Internet. Didn't work.
    I visited the page where it shows you all the programms interfering with the game. I have none of those.
    Graphics driver updated. Didn't work.
    I'm 100% out of ideas. Did work :D
    Jokes aside, I'm literally out of ideas.
    Need halp D:
    Since it is always asked for in other threads, the DxDiag is attached too.
    I have looked into the log files and Im too stupid too find the error (besides the fact that its just a LOT of text) so I'm just gonna post the latest one too.

    Attached Files:

  2. lulamae

    lulamae Well-Known Member

    Messages:
    673
    Likes Received:
    304
    Check the directory that held your PA-2019-01-14_183325.txt file and see if you have a .dmp file from the session that crashed. If so, please post it here

    https://support.planetaryannihilation.com/kb/faq.php?id=176
  3. loligerloler2

    loligerloler2 New Member

    Messages:
    10
    Likes Received:
    2
    Done, thanks in advance :) As soon as a solution was found I'll post it here in case anyone else will need future help :)[/QUOTE]
  4. loligerloler2

    loligerloler2 New Member

    Messages:
    10
    Likes Received:
    2
    Alright, so after a couple of days I'm confident I fixed it. Yet, I am not sure why and how. Even the Support struggled with finding the solution for the crashes since none of the logs showed a crash or anything. Not even a proper .dmp file was created by my system so everything got pretty complicated. I changed to the modern build too (via Right clicking on the game > Properties > Betas), deinstalled each and every mod, even deinstalled Discord because the Support assumed (because of the logs) it may crash the game from time to time. So how did I fix it?
    Well, what I did was following:
    Find no solution.
    Turn crazy.
    The End.
    Ok jokes aside, all I did was downloading the casual Planetary Annihilations application with its own launcher. I linked the UberNet Account (or PlayFab? not sure) to my Steam so it was verified that I actually bought the game. I started the Application and installed the game. Then I realized, that it was just the casual game, not the Titans variant. So, I deinstalled it.
    Now, after launching Titans in my Steam library the casual PA turned up again. That was kind of a shock and I hoped not having to buy the Titans game again. I closed the game. Switched via Steam from the modern build to the regular build. And *poof*, everything was fine from then on.
    Had to change all my controls and graphics again because they were reset but the game runs as usual now.
  5. lulamae

    lulamae Well-Known Member

    Messages:
    673
    Likes Received:
    304

    Try again on the modern build
  6. loligerloler2

    loligerloler2 New Member

    Messages:
    10
    Likes Received:
    2
    Sadly doesn't change a thing, still works perfectly fine.
  7. lulamae

    lulamae Well-Known Member

    Messages:
    673
    Likes Received:
    304
    Now I'm confused. Your response seems at odds with itself, although it might just be me.

    Are you saying that you still do not have Titans when running the Modern build through Steam?

    If your are going the PA Launcher route to start the game, the first time you will need to log in through it and verify your game files for it to pull in Titans and the Modern build option.

    I'd really like to get this thing working for you on the Modern build.
    Last edited: January 21, 2019
  8. loligerloler2

    loligerloler2 New Member

    Messages:
    10
    Likes Received:
    2

    Sorry, my bad, I didn't clarify myself enough. The game now runs perfectly fine after what I did in #4, so no more problems. I wrote "Sadly doesn't change a thing" because I know you want to find the cause of the crash and "sadly" I didn't find the answer to what exactly caused me to crash all the time. So using modern build or the standard one does not make any difference concerning the problem I had.
    Still, thanks for your time and help :)

Share This Page