Custom server problem

Discussion in 'Support!' started by kopajglan, August 8, 2016.

  1. kopajglan

    kopajglan New Member

    Messages:
    3
    Likes Received:
    2
    Hi, I am new to this forum. I have tried to set up my own PA: Titans custom server in order to play with my friends with less lags and more player slots. After a few attempts the server seems to be working but I can't find a way to connect to it because the server is not visible in the lobby. I am using Windows 10 and the server is set up on my computer. I port-forwarded this port in my router: 20545. Thank you in advance.

    Here is the server log:
    Code:
    [10:24:58.000] INFO Started at 2016-08-08 10:24:58
    [10:24:58.000] INFO SDL: Built w/ v2.0.4, linked w/ v2.0.4
    [10:24:58.000] INFO Mounting D:\Program Files (x86)\Games\Planetary Annihilation Server\Planetary Annihilation Titans\media\ as /
    [10:24:58.000] INFO Mounting C:\Users\KopajGlan\AppData\Local\Uber Entertainment\PA Server\download\ as /download/
    [10:24:58.000] INFO Loaded buildID 2016053194684
    [10:24:58.000] WARN Crash reporting disabled.
    [10:24:58.000] INFO Starting async parallel for driver with 6 threads
    [10:24:59.093] INFO Successfully created context with configuration 1/9: v4.4 (core)
    [10:24:59.093] INFO HAL initializing...
    [10:24:59.093] INFO OpenGL Vendor: NVIDIA Corporation
    [10:24:59.093] INFO OpenGL Renderer: GeForce GTX 760/PCIe/SSE2
    [10:24:59.093] INFO OpenGL Version: 4.4.0 NVIDIA 368.22
    [10:24:59.093] INFO OpenGL Shader Language Version: 4.40 NVIDIA via Cg compiler
    [10:24:59.093] INFO Vendor flag set to NVidia
    [10:24:59.093] INFO Supported rasterizer capabilities: Gamma correct pipeline, Ranged mapping, Advanced instancing, Advanced shaders, Compute shaders, Persistent buffer mapping
    [10:24:59.093] INFO Unsupported rasterizer capabilities:
    [10:24:59.093] INFO Buffer textures enabled.
    [10:24:59.093] INFO initial size 1280x720
    [10:24:59.093] INFO Loading effects from file /shaders/post.json
    [10:24:59.109] INFO Loading effects from file /shaders/content.json
    [10:24:59.140] INFO Loading effects from file /shaders/impostors.json
    [10:24:59.140] INFO Loading effects from file /shaders/misc.json
    [10:24:59.140] INFO Loading effects from file /shaders/particle.json
    [10:24:59.187] INFO Loading effects from file /shaders/scene.json
    [10:24:59.203] INFO Loading effects from file /shaders/vtex.json
    [10:24:59.218] INFO Log file C:\Users\KopajGlan\AppData\Local\Uber Entertainment\PA Server\log\server-2016-08-08_102459.txt opened
    [10:24:59.218] INFO Starting background thread pool with 6 threads
    [10:24:59.218] INFO GameServerImpl::resetModUpdateAuthToken: Auth token reset to "8ef73c40-4a33-ee4d-b74d-50f7dc53b4ca"
    And the server config:
    Code:
    {
        "server": "D:\\Program Files (x86)\\Games\\Planetary Annihilation Server\\Planetary Annihilation Titans\\bin_x64\\server.exe",
        "serverversion": "D:\\Program Files (x86)\\Games\\Planetary Annihilation Server\\Planetary Annihilation Titans\\version.txt",
        "serverparams": ["headless", "game-mode", "PAExpansion1:Config", "allow-lan","server-name", "PrivateServer", "max-players", "15", "–max-spectators", "5"],
        "pastats": "pastats.com",
        "pastatsport": 80,
        "listonpastats": true,
        "serverip": "[censored]",
        "serverport": "20545",
        "shownregion": "pastats.com"
    }
    Question to the attachment: What does 'no sim' mean? nosim.PNG
  2. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,327
    Likes Received:
    2,125
    You are missing several dashes in your serverparams and some of the dashes are fancy hypens. I think it should be:
    Code:
    "serverparams": ["--headless", "--game-mode", "PAExpansion1:Config", "--allow-lan","--server-name", "PrivateServer", "--max-players", "15", "--max-spectators", "5"]
    The "No sim" just means that no simulation has been started yet. That is, it's just waiting for players to connect and the game to start. You shouldn't see this screen though. The --headless parameter is supposed to suppress it.

    ( @Quitch : I noticed that the guide on Exodus has – instead of --. I think fancy editing software got in the way there.)
    kopajglan likes this.
  3. Quitch

    Quitch Post Master General

    Messages:
    5,775
    Likes Received:
    6,035
    The text is correct on the backend, but it's being displayed wrong. I've switched it to preformatted mode to resolve the issue. Thanks for the report.
    DeathByDenim likes this.
  4. kopajglan

    kopajglan New Member

    Messages:
    3
    Likes Received:
    2
    Thank you for your help, now it works! I will test it with my friend in a couple of days.
    DeathByDenim likes this.
  5. FSN1977

    FSN1977 Active Member

    Messages:
    657
    Likes Received:
    232
    Ohh is there A guide for Windows 10 or did you do it ur self?
  6. kopajglan

    kopajglan New Member

    Messages:
    3
    Likes Received:
    2
    There are 2 guides, one on this forum and one on Exodus site (I'm on the phone, just Google it). As far as I remember, both are for Linux, but you can make it on Windows in similar way. There is a YouTube video in which someone does it on Windows. If you need some help, reply here or send me private message. ​
    FSN1977 likes this.
  7. FSN1977

    FSN1977 Active Member

    Messages:
    657
    Likes Received:
    232
    Okay Thx :)
  8. mwreynolds

    mwreynolds Well-Known Member

    Messages:
    472
    Likes Received:
    294

    Is this the windows guide?

Share This Page