Can't build Catalyst, metal spot is in the way

Discussion in 'Support!' started by Azarath, August 20, 2015.

  1. Azarath

    Azarath Member

    Messages:
    64
    Likes Received:
    18
    I haven't played PA in some time now, then Titans came out and it looked friggin' awesome! And it is.

    So I decided to play some Galactic War and after conquering world after world I stumbled across the red faction's leader.

    One metal planet and three moons. And I had the metal planet all for myself.
    I thought this was going to be too easy. I had built 4 catalysts and when I moved on to build the 5th I couldn't. It was completely impossible. Why? Because one metal spot was upon the build area of the Catalyst.

    I thought maybe this is a new feature. Maybe there's an option to turn "Enable buildings on metal spots On/Off. I paused the game and clicked settings. Nothing in settings and once I was in the settings menu I couldn't get rid of it so I was forced to Alt - F4 the game.

    I would really appreciate the metal spots around the catalysts area to be removed or an option to re-enable buildings upon metal spots.

    Attached Files:

  2. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,325
    Likes Received:
    2,118
    That's odd, because:
    upload_2015-8-20_9-45-52.jpeg
    It seems to be building on top of the metal spot there.

    The catalyst placement is rather finicky though. Next time this happens, could you try putting your mouse precisely on the blue icon itself?
  3. Killerkiwijuice

    Killerkiwijuice Post Master General

    Messages:
    3,871
    Likes Received:
    3,610
    Use the area commands.
    FSN1977 likes this.
  4. Azarath

    Azarath Member

    Messages:
    64
    Likes Received:
    18
    I can try to put it exact on the blue icon. I let you know how it went.
    EDIT: I can confirm putting it on the blue icon does not work. Not with area commands. Not with different fabricators. Not building a metal extractor on top and removing it.
    I managed to once again get the entire metal planet for myself so I ended up nuking the enemy commanders instead.
    I won but it would have saved me time if I could blast away the planets instead of sending scouts to find the commanders so my nukes had something to aim at.

    Area commands didn't do it.
    Been using area commands with the catalysts before because sometimes they can be a bit tricky to put in place but this time it didn't work. Thanks for mentioning it though.
    Last edited: August 20, 2015
  5. ornithopterman

    ornithopterman Member

    Messages:
    37
    Likes Received:
    43
    Same problem here, nothing works in game...

    Attached Files:

  6. DeathByDenim

    DeathByDenim Post Master General

    Messages:
    4,325
    Likes Received:
    2,118
    I still have a hard time getting the same bug. I just made a custom map that has a metal spot right, like so:
    upload_2015-8-20_14-32-45.jpeg
    The fabbers are of course just right in front of it, but you can still see the green dot. The second metal spot is clearly visible.
    I've attached the system I've used to test this on. Could you try it as well and see if it builds catalysts for you? (Just set your resource multiplier to 5.0 for faster building)

    Attached Files:

  7. Azarath

    Azarath Member

    Messages:
    64
    Likes Received:
    18
    I could build catalysts on your custom built system with no problem will all the fabricators.
    If it's not the metal spots that causes the problem, then what could do it?

    But as I mentioned, I nuked them instead so I can't do any more tests on that system.
    If I run into more metal planets that doesn't work in GW, I let you know.
    DeathByDenim likes this.
  8. Bastilean

    Bastilean Active Member

    Messages:
    328
    Likes Received:
    55
    I can confirm that this is still an issue. Also, pathing around construction of the devices is also an issue. I find the game struggles a lot to place the Catalysts as well as queue placing multiple catalysts. Then there are times you just aren't given the ability to build on the obvious catalyst spot like what happened to me today. I even tried drag clicking a large catalyst construction across all the spots but though they appeared they appeared red and wouldn't initialize a construction
  9. Bastilean

    Bastilean Active Member

    Messages:
    328
    Likes Received:
    55
    Note: my issues were not metal spot related. Also these issues were in Galatic War

Share This Page