Can no longer run PA - just get black screen

Discussion in 'Support!' started by davedontmind, October 21, 2019.

  1. davedontmind

    davedontmind Member

    Messages:
    36
    Likes Received:
    29
    I've come back to PA:T after a couple of months off, and now when I start the game I just get a black screen with the in-game mouse cursor. I can move the cursor around, and Alt-F4 works to exit, but that's all I can do.

    I've tried:
    • validating the files with Steam
    • removing and re-installing PA:T
    • clearing the download folder in %LOCALAPPDATA%\Uber Entertainment\Planetary Annihilation
    • removing the %LOCALAPPDATA%\Uber Entertainment\Planetary Annihilation folder entirely
    • updating my graphics drivers to the latest (nvidia 436.48)
    I still get the same problem - Any suggestions? Is there anything I can look at to gather more information?
    grandhomie likes this.
  2. davedontmind

    davedontmind Member

    Messages:
    36
    Likes Received:
    29
    After posting the above issue, I just happened to browse my previous posts to this forum to see what I'd been posting about in the past, and I spotted one where, to fix a problem I had with Crossfire on my AMD graphics card (at the time) I'd added the --software-ui option to the PA:T launch options in steam.

    I've since moved on to an nVidia graphics card, so that option is no longer necessary, and removing it seems to fix the black screen problem. Leaving this here in case anyone else has the same issue.
    grandhomie and lulamae like this.
  3. ViolentMind

    ViolentMind Active Member

    Messages:
    394
    Likes Received:
    186
    I'm having a problem lately where I can't load the game (Titans). The game load screen comes up, but it never gets by the Mounting Client Mods message below and just kind of crashes and returns me back to Steam with no errors. It does that no matter how many times that I attempt to load the game. The only thing that works for me to fix it is to go to the Properties for the game in Steam on the Local Files tab and run the "Verify Integrity of Game Files..." option. It never finds any issues, but after running that, the game seems to load up fine. It's just weird that I need to do that so often.

    Hope that helps if anyone else is having the same issue.
  4. lulamae

    lulamae Well-Known Member

    Messages:
    690
    Likes Received:
    305
    Clear your download cache - https://support.planetaryannihilation.com/kb/faq.php?id=19

Share This Page