Black screen on startup

Discussion in 'Mac and Linux' started by parallaxbeta, May 12, 2019.

  1. parallaxbeta

    parallaxbeta New Member

    Messages:
    4
    Likes Received:
    0
    The title says it all really. I have been wanting to buy this for a while, and when I saw it going cheap on humble, I jumped at the opportunity. On startup, the game plays a video cinematic, and then drops me into a black screen, with a chat box at the bottom, but otherwise no interface. Sound works fine, and I can make some interface sounding noises by mashing my keyboard.

    uname -a: Linux chevron 5.0.0-trunk-amd64 #1 SMP Debian 5.0.2-1~exp1 (2019-03-18) x86_64 GNU/Linux

    I have uninstalled, reinstalled, and purged the configuration folder, and installed on 2 different devices (an SSD and a CephFS folder).

    I know that this symptom is rather common, but I have iterated through and combined all of the fixes I could find, but to no avail.

    Anything else for me to try?

    Attached Files:

  2. lulamae

    lulamae Well-Known Member

    Messages:
    679
    Likes Received:
    304
    Your file indicates you loaded the modern-pte build. Try loading the modern stable build.
  3. parallaxbeta

    parallaxbeta New Member

    Messages:
    4
    Likes Received:
    0
    I tried the test build to see if that would change anything. The effect is the same regardless. I have attached a new (old?) log file

    Attached Files:

  4. rkrk

    rkrk New Member

    Messages:
    1
    Likes Received:
    0
    I also experience same issue. My log also contains "Uncaught TypeError" and "Assert failure" errors. Part of UI loads for me. I can see community help strip at the bottom of the screen. Rest of it is black. I can hear mouse-over button sound effects if i move mouse in the area where main menu is supposed to be. My log attached.

    OS: Archlinux
    Driver: amdgpu (mesa)
    GPU: rx580

    Tested with and without libudev.so.0 symlink workaround. Same thing happens in both cases.

    Attached Files:

  5. lulamae

    lulamae Well-Known Member

    Messages:
    679
    Likes Received:
    304
  6. Zappor

    Zappor New Member

    Messages:
    2
    Likes Received:
    0
    It could be improved some time in the future: gamingonlinux : planetary-annihilation-titans-has-a-new-test-build-out-improved-ai-and-coherent-ui-update.13625 (can't paste full link)
  7. SuperTux95

    SuperTux95 New Member

    Messages:
    2
    Likes Received:
    0
    I have this problem too... This game has been broken for years on Linux, but I bought this game because it was available on Linux, please fix this engine bug. It still because of this bug? bugs.freedesktop.org /show_bug.cgi?id=65968#c12

Share This Page