Audio bug on Linux Debian 8

Discussion in 'Mac and Linux' started by teopost2, April 24, 2017.

  1. teopost2

    teopost2 New Member

    Messages:
    1
    Likes Received:
    0
    I just bought the game through Steam, I played the first tutorial mission and then I quit the game, now when I start the game, and the main menu shows there is no sound: even if i play i can't hear nothing.
    At first i tought that the audio was being redirected to the monitor speakers, and since i am using an headset speaker, i tried redirecting the audio stream to the right sound card.
    However, opening pavucontrol with the application still running, results in the game making some strange random noises, and pavucontrol UI freezes.
    I tried deleting game settings located in ~/.local/Uber Entertainment and that seemed to work because the game movie that loads before the main menu, makes clear sound, but once the menu shows up, sounds goes away again.I tried deleting and redownloading the game, and I even tried checking the integrity of the game cache, but nothing worked.
    Game logs located in ~/.local/Uber Entertainment/Planetary Annihilation/log/ don't give particular errors related to sound issues.

    What could it be?
    What is still left to try?

    I am using Debian 8 with xfce4 and pavucontrol for sound settings.
    The audio device im using is: LOGITECH Headset H340.
    I attached the game log file.

    Attached Files:

  2. mason1920

    mason1920 New Member

    Messages:
    3
    Likes Received:
    0
    This is from Debian's wiki with slight modification to fix it being outdated and remove unnecessary information.

    No Sound In Games?
    rm -rf ~/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/alsa-lib
    rm -rf ~/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/alsa-lib
    rm ~/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libasound.so.*
    rm ~/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libasound.so.*

  3. cdrkf

    cdrkf Post Master General

    Messages:
    5,750
    Likes Received:
    4,831
    Hi, sorry no one got back to you on this for so long!

    Is that a USB headset by any chance? I remember PA used to have issues with USB audio devices- now I think that was resolved on Windows however I'm unsure what effect it will have under Linux. In my experience using a 3.5mm output with headphones / speakers should work fine. The other thing that spring to mind is if there's an issue using pavucontrol with PA. I'm unfamiliar with that tool however have you tested using the default sound drivers?

Share This Page